6 Replies Latest reply on Mar 30, 2015 9:45 PM by Sandy_Intel

    Can't turn off SRIOV on CentOS 7 after its turned on

    morganyang1982

      I'm running CentOS 7 with a dual NIC nianctic (10G, ixgbe), and I have been experimenting with SRIOV.

       

      I turned on SRIOV via the following command"

       

      echo 8 > /sys/bus/pci/devices/0000\:01\:00.0/sriov_numvfs

       

      However, this setting seems to be permanent. Even when I reboot, sriov_numvfs is is automatically enabled and set to 8. I don't have a startup script that is setting it.

       

      I'm curious if there's a way to permanently disable sriov. I'm currently disabling it in a startup script, but because of ixgbevf, my Ethernet device ordering gets screwed up.