2 Replies Latest reply on Apr 7, 2015 11:07 AM by jkorten123

    Intel NUC Kit D54250WYK stuck on "Intel NUC" power-on screen

    jkorten123

      I currently have BIOS Update [WYLPT10H.86A] WY0035.BIO installed on my NUC D54250WYK.

       

      The unit has a "Crucial CT256M550SSD3 256GB M550 mSATA Internal SSD" and 1x "Crucial CT102464BF160B 8GB DDR3 PC3-12800 Unbuffered NON-ECC 1.35V 1024Meg x 64" which I believe are both on your supported hardware list (or at least the "this might work" hardware list). I'm currently getting a Error 500 when trying to access the tech docs at http://www.intel.com/p/en_US/support/category/dsktpboards/dk-d54250wyk/doc_guide so I can't confirm that.

       

      I installed OpenBSD in a very standard way, but something that the installer has done has left my NUC unbootable as long as the mSATA drive is still inserted into its slot. It remains, as far as I can tell indefinitely, on the "Intel NUC" power-on/post screen (the screen with the F2, F7, F10 options in the lower right). No keyboard actions seem to get me further than this.

       

      If I remove the mSATA drive I can choose the F? options and get into the UEFI/BIOS settings. After this the thing can boot from USB or network just fine, just not while the mSATA drive is inserted.

       

      This is a recurrence of a problem I had earlier with another OpenBSD install. I had solved the earlier issue with a UEFI/BIOS upgrade (from 22 -> 35) and was able to boot from the mSATA. I have now reset the UEFI/BIOS to factory defaults (but I'm still on BIOS 35) and I'm still unable to boot.

       

      I have a couple of questions:

      a. Presumably the only thing the OpenBSD installer has done is perhaps write some dubious data or MBR to the mSATA. Why would this prevent the NUC from at least being able to boot into the UEFI/BIOS config screen or boot from some other medium?

      b. Is there a way I can re-flash BIOS 35 (or a newer one) and fix the issue?

       

      UPDATE: I tried reflashing both BIOS 35 and 33 and I have the same problem. I also set the hard disk detection delay in the Devices -> SATA section to 10 seconds to see I could somehow select another boot medium before it tried to detect the mSATA but still same issue.