6 Replies Latest reply on Apr 8, 2015 6:53 PM by YONGYONG

    ehci_pci caused the error -110?

    YONGYONG

      I am using Galileo Gen1 with kernel 3.17. I found the below error message during boot process:

       

      [  749.161973] ehci-pci 0000:00:14.3: port 2 reset error -110

        [ 749.790230] usb usb2-port2: Cannot enable. Maybe the USB cable is bad?


      I found it is caused by the ehci-pci.ko module.  It caused the USB host does not work. I have to rmmod the ehci-pci.ko.

       

      Anyone encountered this problem, what is the root cause ?

        • 1. Re: ehci_pci caused the error -110?
          mhahn

          where did you get 3.17 for Galileo?

          who built it?

          I guess it has just not been properly ported from the standard 3.8 kernel

          • 2. Re: ehci_pci caused the error -110?
            YONGYONG

            On the github, there is a meta-micro-galileo, it includes the 3.17 kernel. I built it locally. Only the ehci-pci has problems, all others are oaky.

            • 3. Re: ehci_pci caused the error -110?
              mhahn

              then I guess arfoll should be able to comment

              • 4. Re: ehci_pci caused the error -110?
                YONGYONG

                Thanks for your comment. I just tested the offical iotdk image, the same error message:

                [   18.381924] ehci-pci 0000:00:14.3: port 2 reset error -110

                [   19.010187] hub 1-0:1.0: Cannot enable port 2.  Maybe the USB cable is bad?

                [   19.081958] ehci-pci 0000:00:14.3: port 2 reset error -110

                [   19.981889] ehci-pci 0000:00:14.3: port 2 reset error -110

                [   20.821889] ehci-pci 0000:00:14.3: port 2 reset error -110

                [   21.661888] ehci-pci 0000:00:14.3: port 2 reset error -110

                [   22.501900] ehci-pci 0000:00:14.3: port 2 reset error -110

                [   23.130159] hub 1-0:1.0: Cannot enable port 2.  Maybe the USB cable is bad?

                [   23.137450] hub 1-0:1.0: unable to enumerate USB device on port 2

                 

                galileo login: root

                root@galileo:~# cat /proc/version

                Linux version 3.8.7-yocto-standard (brendanl@iotd01) (gcc version 4.8.2 (GCC) ) #1 Fri Feb 6 08:29:08 GMT 2015

                • 5. Re: ehci_pci caused the error -110?
                  CMata_Intel

                  Hi YONGYONG ;

                   

                  Do you have updates in this?

                   

                  I'm using the IoT image from here IoT - Download the Software | Intel® Developer Zone

                   

                  I'm getting the next results:

                  root@galileo:~# cat /proc/version
                  Linux version 3.8.7-yocto-standard (brendanl@iotd01) (gcc version 4.8.2 (GCC) ) #1 Fri Feb 6 08:29:08 GMT 2015
                  root@galileo:~# dmesg | grep hub
                  [    3.395166] usbcore: registered new interface driver hub
                  [    4.288271] hub 1-0:1.0: USB hub found
                  [    4.294931] hub 1-0:1.0: 2 ports detected
                  [    7.474757] hub 2-0:1.0: USB hub found
                  [    7.478612] hub 2-0:1.0: 2 ports detected
                  root@galileo:~# dmesg | grep ehci
                  [    4.092762] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
                  [    4.143148] ehci-pci: EHCI PCI platform driver
                  [    4.147879] ehci-pci 0000:00:14.3: enabling bus mastering
                  [    4.147938] ehci-pci 0000:00:14.3: setting latency timer to 64
                  [    4.147978] ehci-pci 0000:00:14.3: EHCI Host Controller
                  [    4.180192] ehci-pci 0000:00:14.3: new USB bus registered, assigned bus number 1
                  [    4.187908] ehci-pci 0000:00:14.3: enabling Mem-Wr-Inval
                  [    4.188035] ehci-pci 0000:00:14.3: INSNREG01 is 0x007f007f
                  [    4.193682] ehci-pci 0000:00:14.3: INSNREG01 is 0x007f007f
                  [    4.247903] ehci-pci 0000:00:14.3: irq 19, io mem 0x9000d000
                  [    4.280159] ehci-pci 0000:00:14.3: USB 2.0 started, EHCI 1.00
                  

                   

                  When you connect the USB client to your PC, are you able to see the device? I suggest you to follow this guide Intel® Galileo - Programming SPI Flash through the UEFI Internal Shell and then try again with the IoT image.

                   

                  Regards;

                  CMata

                  • 6. Re: ehci_pci caused the error -110?
                    YONGYONG

                    Thanks CMata for your update! Let me test on my boards first, I will post the results later