10 Replies Latest reply on Mar 19, 2015 4:55 PM by ForumMigrationAdmin

    Corrupted FW - no booty

    ForumMigrationAdmin

      Couple days ago I turned the Arduino edison off - I was writing a upm library and didn't need the system on.

      Turned it on this evening and chaos..........

      ******************************

      PSH KERNEL VERSION: b0182727

                      WR: 20104000

      ******************************

       

      SCU IPC: 0x800000d0  0xfffce92c

       

      PSH miaHOB version: TNG.B0.VVBD.0000000c

       

      microkernel built 23:15:13 Apr 24 2014

       

      ******* PSH loader *******

      PCM page cache size = 192 KB

      Cache Constraint = 0 Pages

      Arming IPC driver ..

      Adding page store pool ..

      PagestoreAddr(IMR Start Address) = 0x04899000

      pageStoreSize(IMR Size)          = 0x00080000

       

      *** Ready to receive application ***

       

       

      U-Boot 2014.04 (Oct 14 2014 - 15:19:04)

       

             Watchdog enabled

      DRAM:  980.6 MiB

      The above keeps cycling - once or twice it has got past this and started to load Yocto - then it dies and jumps back to the start again.

      I have tried to do a FW reset (I am on a mac running OS X - latest version). Have downloaded Homebrew, run brew doctor, done the  brew install dfu-util coreutils gnu-getopt and downloaded the latest yocto image. (edison-image-ww36-14). Cd'd to the unzipped image and run ./flashall.sh

      Power cycled board and held down RM and FW - but flash appeared to not find DFU device 8087:0a99 - eventually flash timed out with: Timed out while waiting for dfu device 8087:0a99 - tried power cycling board and holding down FW button but lots of nothing appeared to be happening. eventually just let go of the button (with nothing appearing to be happening and power cycled again (where it went into the boot/crash/boot cycle again. So unless I have done something really really bad it appears that 1. System cannot boot. I cannot repair FW via home-brew and cannot get system back from flash. Would really appreciate some advice at this stage. BTW - just tried the power cycle with FW pressed and eventually the system did reboot - it would appear recovery failed however because still get same syndrome of boot/reset/boot