9 Replies Latest reply on Jan 20, 2016 2:49 AM by Srinidhi

    Galileo Gen 2 XDK

    bengels

      Having trouble getting the XDK going.

      I've been following the steps here: https://software.intel.com/en-us/html5/documentation/getting-started-wit...

      I've setup the Galileo, I installed the linux image from that guide, and can even run sketches which I did to get an IP. Strangely enough I only have an ipv6 address whereas on the regular Yocto image I had ipv4 too, not sure if this makes a difference.

      The issue is around the XDK software, the Galileo does not show up. I have Bonjour, I tried a manual connection but it failed. I tried to do this command over telnet: systemctl enable xdk-daemon... but systemctl does not exist.

      What is going on here, do I have the wrong image I got this one directly from the guide and have followed all the steps.

        • 1. Re: Galileo Gen 2 XDK
          kona

          Were you able to connect to the board using serial cable? If you dont have an IP for your Galileo you can set it using Arduino sketch. From your post it seems you have set an IP. Now either you can ssh to the board using the IP (using LAN cable) or using serial connection (using USB to FTDI cable) Once you login to the Edison device you will be able to run the command  systemctl enable xdk-daemon. Btw which OS are you on?

          • 2. Re: Galileo Gen 2 XDK
            contactdomisemail

            That's what I'm saying... I do not have the systemctl command

            Poky 9.0.2 (Yocto Project 1.4 Reference Distro) 1.4.2 clanton

            Is the version I downloaded from the guide for the XDK. What's interesting is for the regular image:http://downloadcenter.intel.com/confirm.aspx?httpDown=http://downloadmir... from here I get both an ipv4 and ipv6 automatically.

            On the image from this guide I just get the ipv6 automatically. I was able to telnet into the device and once again when I attempt to run  systemctl enable xdk-daemon I get:

            /bin/sh: systemctl: not found

            • 3. Re: Galileo Gen 2 XDK
              ForumMigrationAdmin

              Have you downloaded this image https://software.intel.com/sites/landingpage/iotdk/board-boot-image.html on to the SD card. If you boot this image from SD card once the system is booted you will see  iot-devkit (Intel IoT Development Kit) 1.1 quark017332 ttyS1. Then you will have systemctl working.

              To be sure you can check the blinking LED showing SD card boot status near LAN port.

              • 4. Re: Galileo Gen 2 XDK
                ForumMigrationAdmin

                Your error seems consistent with either a faulty, blank or otherwise incorrect SD card. ie you can download sketches, find an IP address etc all without having a functional SD.  A quick test is to check the SD led as you power up. The light is effect a disk access light, and should blink intermittently for 2-3 minutes as the system boots.

                • 5. Re: Galileo Gen 2 XDK
                  contactdomisemail

                  I have the exact 100% completely the absolutely same issue. I can connect to the device just fine. I also checked (according to this pretty useful SD card verification method: http://www.hofrock.com/sd-card-issues/), and yes: I am booting from SD card and it is running fine.

                   

                  So:

                  1. I boot from SD (verified)

                  2. PC and device are connected via ethernet router using DHCP (MAC Airport)

                  3. I can connect via SSH (using XDK's "SSH Terminal") and have verified the correctness of the IP address using `ifconfig`

                  4. XDK fails to automatically find the device, using the automatic scan option

                  5. I have manually added the device to the list.

                  6. The "IoT XDK" tab refuses to connect, spitting out the error message: "Error forwarding port" - "Error: (SSH) Channel open failure: Connection refused"

                  7. Using SSH, it also cannot find `systemctl` which I assume is the culprit of above error message.

                   

                  I am running Windows 7 with the most recent everything (just installed everything). I also checked my firewall.

                  • 6. Re: Galileo Gen 2 XDK
                    kona

                    Have you tried following the latest getting started document? you can also check this article and reconfirm the steps followed for XDK installation.

                    If you have the FTDI serial cable, can you try connecting the board using putty and try run the command systemctl enable xdk-daemon

                     

                    Regards, Raghu kona

                    • 7. Re: Galileo Gen 2 XDK
                      bengels

                      Using a Mac, this tutorial worked better for me and got me all connected.

                       

                      https://learn.sparkfun.com/tutorials/galileo-getting-started-guide

                      • 8. Re: Galileo Gen 2 XDK
                        Srinidhi

                        Hello..I'm new to Galileo Gen 2 development environment. I'm able to build the full image of Yocto for Galileo and booted the image with SD card.

                        However I see Intel XDK not able to connect to the target since I see that the needed xdk daemons does not exist in target. Neither systemctl. I have

                        connected to the net with proper IP address and able to ping from other machines as well.

                         

                        I have the following images built

                        bzImage

                        core-image-minimal-initramfs-clanton.cpio.gz

                        Image-full-clanton.ext3

                        boot/grub/grub.conf

                         

                        However, If I download the binaries from Making a bootable micro SD Card with Windows* | Intel® Developer Zone then it works and i'm able to connect to the target through XDK.

                        Is there anything I'm missing?

                        • 9. Re: Galileo Gen 2 XDK
                          Srinidhi

                          I guess the required stuffs are to be present in the mmcblk0p2 partition..I guess the win32diskImager does the job in case of prebuilt binaries