4 Replies Latest reply on Mar 19, 2015 3:16 PM by ForumMigrationAdmin

    Edison+Arduino+MRAA+Python works only first time

    ForumMigrationAdmin

      Hi,

      very strange problem

      i have an Edison Arduino board,

      i installed ubilinbux on it

      also installed lib mraa (python)

      i tried both samples GPIO in and out

      https://github.com/intel-iot-devkit/mraa/tree/master/examples/python

      blink-io8.py and hello_isr.py

      if in unplub both usb cables from the arduino, reconect back login and run the sample everything works perfect

      if i start killing the sample (ctrl+Z) or kill python process or close python interpreter, and try again to run the sample, nothing works

      let me explain nothing works:

      the isr sampel si not working at all

      but the gpio out sample, if i use pin 10 instead of turning on the led i added on pin ten (like it was doing immediately after power on) now some green led closer to the 6 pin header (3x2) is turning on and off, and if i mess with this led, i lose the wifi/network connectivity (cannot ping in or out to the edison linux) but the putty over the com port works fine

       

      anyone any ideas or explanation into how this edison works and what gets messed up and eventually how it can be made again to work. (i tried to press all the 5 buttons present on the board and 1 to 4 they are not making the problem go away, anyway read teh docs about them and those buttons have all kind of functionality, and 5 resets the linux but still does not make io work, i need to power down completely the board and power it back on to get io back working)

       

      hope this problem with the IO getting all messed up after first sample run makes sense to anyone.