7 Replies Latest reply on Jul 5, 2015 11:52 AM by wolfv

    Wake on USB from S5

    MattMe

      Hi, I've recently purchased a few i3 and i5 NUCs (NUC5i3RYK & NUC5i5RYK) for the office and have encountered an issue that seems similar to some common issues on the forum on internet in general, however I can't find any answers.

      The issue is with powering on the NUC from a USB keyboard or mouse from S5 state.  I noticed when I first set up a few NUCs the power on from USB seemed to work, but it has since stopped.  I have not changed any settings. Most other discussions seem to be around powering on from USB remotes and on older models.

       

      Details around my setup:

      I have installed Windows 7 Pro (with SP1) in legacy mode, and installed all Windows update.  I have downloaded and installed all the latest drivers and BIOS from this month on the Intel NUC download page. I have supported Kingston memory (4GB - KVR16LS11/4)) and Crucial (M550 M.2 128GB) SSD installed. I have checked in Windows Device Manager that the checkbox for 'Allow this device to wake the computer' is checked for both the keyboard (Microsoft Wired Keyboard 600) and mouse (Microsoft Comfort Mouse 4500). In the BIOS I have 'USB S4/S5 Power' checked, as well as 'Wake on USB from S5'.

      I have also found that in some cases the keyboard/mouse will not even wake the NUCs from S3 state.  I have to press the physical power button on the computer.


      I have the i5 NUC at home running Windows 8.1 which for while the power on from USB was working fine, even with a wireless keyboard, however that too has since stopped working and I have tested with a wired keyboard which made no difference.


      I'd like to roll these out across the business as our standard desktop as I think they're cool little devices that are more than sufficient for Office applications and web browsing (95% of staff), however as we plan to VESA mount them to the back of the monitors this issue will make them very impractical.  I can't ask users to start moving their screens every time they want to power on their computers, not least because something is likely to get broken!

       

      Any suggestions or ideas would be greatly appreciated.  I have already opened a case with Intel support, but thought it's worth asking here too.

       

      Thanks, Matt.

        • 1. Re: Wake on USB from S5
          malch

          I'm running Linux versus Windows and have been having other wake problems. It seems to me that your BIOS settings and Windows options are correct and, in any event, the system should be operating consistently. You've probably done this already but... I would check to confirm that the problem arises with more than just one keyboard and mouse.

           

          I am beginning to suspect something flaky with the BIOS/ACPI implementation: tables getting messed up or whatever.

           

          I wish Intel were more forthcoming and willing to share what they know about BIOS issues currently under investigation. remediation or test. Unfortunately, the policy seems to be "say nothing" until the next BIOS update is formally released.

          • 2. Re: Wake on USB from S5
            MattMe

            It does seem a little flaky, I agree.

             

            I've tried multiple NUC systems all with brand new mice and keyboards (although, admittedly the same model) in the office environment.  At home I have 3 completely different types and manufacturers of keyboard I have tried, all 3 of which have the same issue.  2 being wireless (USB dongle type) and 1 being wired USB.  I doubt it's the keyboards that are to blame after having tried all these.

             

            Today after writing this post and going back into BIOS, not changing anything, but saving before exiting, this test system I have no appears to be waking from USB.  The other one opposite me where I haven't gone back into BIOS seems to still have the same issue.  I'll leave them both overnight to see if it's to do with longer periods of being powered off that causes the issue.

            Flaky!

             

            It can be very frustrating when companies don't utilise their online communities who would be willing to test alpha/beta BIOS or drivers.  Or even like you suggest, post about potential issues that we could investigate and see if we experience the same problems.  I guess they're afraid to scare off potential customers.  Personally I'd prefer the proactive and open environment, which would give me confidence to buy their products.

             

            What issues have you had with Linux wake from USB?  What version of Linux is it?  Is it just from S5 or S3/S4 as well?

            • 3. Re: Wake on USB from S5
              malch

              MattMe wrote:

              What issues have you had with Linux wake from USB?  What version of Linux is it?  Is it just from S5 or S3/S4 as well?

              Lubuntu 15.04 beta (for HD6000 graphics). Perhaps more important is the kernel:  3.19.0-9-generic.

               

              I can wake from S5 (reliably it seems) using WOL and/or an IR remote and USB receiver/dongle.

               

              Trouble is... the system randomly wakes itself from S5 from time to time. It happens even if I disable all of the wake related options in the BIOS and disconnect the LAN and USB devices.

               

              Worse, with Linux, I can't find any way to tell what device initiated the wake. Even if I deliberately wake the machine (e.g. with WOL) I can't find anything in the system logs which reflects that.

               

              I can't help thinking it may be related to this issue reported with Haswell machines:

               

              [PATCH 3.8 66/81] xhci: Fix spurious wakeups after S5 on Haswell

               

              or something like it -- i.e. failure to initialize a device or data structure.

               

              Either way, it pretty clear to me that Linux needs some equivalent tool to Windows "powercfg -lastwake". Plenty of users (not just NUC users) have been banging their heads on that for a while.

              • 4. Re: Wake on USB from S5
                MattMe

                I'd read lots about the random wakeups from S5 with the last gen too.  I'm not that familiar with Linux beyond running a couple VMs.  Are there no third party tools you could try?  Or disconnect your USB overnight to see if that prevents them starting up?

                 

                Yesterday I got three test machines together and tested the Wake on USB from S5.  It seems that it works *most* of the time if I attempt to wake within an hour or so.  I left them overnight last night and this morning only one of the three booted from keyboard or mouse input.  The other two are still sat here not powering on.  It's a little upsetting.

                 

                I'm guessing there won't be a fix and I'll just have to wait for a BIOS update, but it will certainly make me reconsider the possibility to roll these out across the business.

                • 5. Re: Wake on USB from S5
                  MattMe

                  I have found the issue with my wireless keyboards running Windows 8 is resolved by disabling the fast startup option.

                  Control Panel > Power Option > Choose What Power Buttons Do > Shutdown Settings > un-tick Turn On Fast Startup.

                  It's a shame this is the issue, as fast start-up is a great feature of Windows 8 and 8.1.

                   

                  My Windows 7 machines seem to be behaving better now since re-saving the settings in the BIOS.  Not sure if this is due to BIOS upgrades.  Perhaps after upgrading the BIOS the issue occurs and requires the settings reconfiguring. I have also noticed that they will only wake from USB mouse input, not keyboard recently.

                  I will investigate this further one I have some more units to test.

                  • 6. Re: Wake on USB from S5
                    wolfv

                    I am having a similar problem with my Haswell Intel NUC Kit D54250WYK.  USB does not wake system from S3 sleep (blinking power button).

                     

                    When I had Windows 7 installed, it would wake from sleep via mouse, but not the keyboard.

                     

                    Last week I changed the operating system from Windows 7 to Fedora 22 (Linux Kernel 4.0, GNOME 3.16).

                    After installing Fedora 22, the mouse and keyboard do not wake the PC, but the power button does.

                    Also, in Fedora 22, the mouse becomes unresponsive every few hours; replugging it's USB restores the mouse.

                    The system has one keyboard and one mouse, which are plugged into a USB hub.

                     

                    The BIOS secondary power settings seem correct (BIOS > Advanced > Setup > Power > Secondary Power).

                    What else is there to check in the BIOS?

                    • 7. Re: Wake on USB from S5
                      wolfv

                      malch wrote:

                       

                      Lubuntu 15.04 beta (for HD6000 graphics). Perhaps more important is the kernel:  3.19.0-9-generic.

                       

                      I was suspending NUC with Linux and eventually my NUC wouldn't boot.  The fix is to not suspend NUC from Linux until the NUC BIOS is patched.  Here are the details: https://communities.intel.com/thread/76708