9 Replies Latest reply on Aug 17, 2015 10:45 AM by Intel_Alvarado

    Edison Wifi connection very slow

    ForumMigrationAdmin

      1. Edison, flashed with "edison-image-ww05-15" image.  uname -r gives 3.10.17-poky-edison+

      2. iwconfig wlan0 power off to disable power management.  The systemctl start wifi-power-management-off does not work.

      3. The connection over wired USB connection is just fine.  Both SSH and the serial connection is just fine. The ping latency is just fine < 10 ms.

      4. Wifi is configured, wpa_supplicant is enabled to enable wifi automatically after every reboot.

      5. Then disconnected the USB, reboot, trying to connect to Edison using Wifi

      I am seeing the following problems,

      a. The pings are very slow (@1.5seconds), missing few pings also.

      b. The wlan0 power management is on (after reboot the setting is disabled).

      c. The SSH connection establishment is too slow.

      b. Every time the first character on the terminal is missing.

      Please help to resolve these issues.

        • 1. Re: Edison Wifi connection very slow
          ForumMigrationAdmin

          Try setting up the device with:

          1configure_edison --setup

           

          It should let you set the device name, password and wifi. Do this through the USB connection.

          Also, make sure that you upgrade to the latest version with this:

           

          1configure_edison --upgrade

           

          Check that you have the latest version with this:

           

          1configure_edison --version

           

          And check the latest available version with this:

           

          1configure_edison --latest-version

           

           

          samontab.com

          • 2. Re: Edison Wifi connection very slow
            ForumMigrationAdmin

            Hi Samontab,

            Appreciate the response.

            The Wifi was configured using "configure_edison".

            Also, in my system, the configure_edison --setup command does not work, see the response below.  Also, --version and --latest-version options also does not work in my system.  The version info is retrieve using uname -r and is posted in previous post.

            root@myedison:~# configure_edison --upgrade

            Incorrect input. Redirecting to --help

              Interactive configuration options:
                (none)                  Goes through changing the device name, password, and wifi options.
                --name or -n            Changes the device name
                --password or -p        Changes the device password
                --wifi or -w            Changes the wifi options

              Non-interactive configuration options
                --changePassword        Changes the device password to the following argument
                --changeName            Changes the device name to the following argument

              Other options
                --help or -h        Displays these help options
                --server            Starts the server (testing only)

            - Thanks,

            • 4. Re: Edison Wifi connection very slow
              ForumMigrationAdmin

              Thank you for all the guidance provided.

              I was making a mistake when upgrading the flash to the latest image of Edison.

              I was copying the correct files into the "Edison" drive, but was issuing the command "reboot" instead of "reboot ota".

              Once I gave the correct command the system rebooted, the issues mentioned in this thread have gone away except disablement of wlan0 power management during reboot.

              I did copy the file as suggested in the Edison wifi user guide "create a file with the name wifi-power-management-off.service and save it in the /lib/systemd/system folder" with the script as suggested.  I will debug this further.

              - Thanks,

              • 5. Re: Edison Wifi connection very slow
                ForumMigrationAdmin

                All of the symptoms you are seeing are indicative of a failed firmware upgrade, ie you are still running the original firmware.

                The telltale piece is the missing --setup flag in the configure_edison command. An easier way to detect a successful reflash is to rename your board, before attempting.  The sign of a successful reflash is that your board name will be reset back to "Edison".

                My recommendation is to run the board off a separate power supply, and to use both USB cables to setup the firmware reflash, and then remove the USB  cable that exports the Edison share drive, ie keep the serial port.  The issue with a failed reflash are many, but on-access virus scan, USB power negotiation and other things can affect this.

                • 6. Re: Edison Wifi connection very slow
                  Intel_Alvarado

                  Hi ForumMigrationAdmin,

                   

                  What is your question specifically?  This seems to be more an email interaction than a forum question. From what I understood from this you have questions related only to power management right?

                  Take a look at these links, you might find them helpful

                   

                  https://communities.intel.com/message/282337#282337

                  https://communities.intel.com/message/264700#264700

                   

                  Regards

                  Sergio

                  • 7. Re: Edison Wifi connection very slow
                    jblackston

                    The Wifi connections are slow. If you connect to a PC via AP mode and ping your module I get about 20ms or so. When I connect the module to my network and then ping the module from a desktop PC that's connected to the network via Ethernet the ping is well over 150ms. If I ping from that same desktop to my laptop which is connected via Wifi my ping is around 10ms. There is for some reason added network delay when you are in infrastructure mode. My module is also running the latest firmware, 120.

                     

                    I've posted this question on this forum for some time and haven't gotten any response.

                    • 8. Re: Edison Wifi connection very slow
                      beckmx

                      hello, I have the same error, slow connection over wifi when trying to SSH to the board, how can I be sure I am running the latest image?

                      • 9. Re: Edison Wifi connection very slow
                        Intel_Alvarado

                        Hi,

                         

                        If you are running the latest Yocto image and run: configure_edison –version you should see 159 as the output. If you don’t see 159 then you are not running the latest image; in that case I’d suggest you update to the latest.

                         

                        Sergio