9 Replies Latest reply on Apr 20, 2015 7:06 AM by JPMontero_Intel

    Root size limit...

    DaveInDurban

      I planned to use the Edison as a controller with a web service interface and a small database. After getting node.js going, I installed express and was about to install MongoDB, but decided to check the disk space, and saw the root partition is 91% full. After looking around the forums, I see it is 500MB by default, and there is apparently a 640MB limit. Apparently growing it is not straight forward.

       

      I never thought about this on my Raspberry Pi's: For example I have the Apache web server, OpenSSL, MySQL, drivers and libraries for some hardware, and 2 years of accumulated stuff on several of them, not to mention all the pre-installed apps. They appear not to have a limit to the root partition.

       

      Am I misunderstanding something? I'm not very good with Linux, though I have managed to get by on the Pi for a few years.

       

      Edison:

      Filesystem                Size      Used Available Use% Mounted on

      /dev/root              463.9M    387.5M    40.6M  91% /

      devtmpfs                479.9M        0    479.9M  0% /dev

      tmpfs                  480.2M        0    480.2M  0% /dev/shm

      tmpfs                  480.2M    496.0K    479.7M  0% /run

      tmpfs                  480.2M        0    480.2M  0% /sys/fs/cgroup

      systemd-1                5.7M      5.3M    462.0K  92% /boot

      systemd-1                2.2G    53.2M      2.2G  2% /home

      tmpfs                  480.2M      4.0K    480.2M  0% /tmp

      tmpfs                  480.2M        0    480.2M  0% /var/volatile

      /dev/mmcblk0p5        1003.0K    19.0K    913.0K  2% /factory

      /dev/mmcblk0p10          2.2G    53.2M      2.2G  2% /home

      /dev/mmcblk0p7            5.7M      5.3M    462.0K  92% /boot

       

      Raspberry Pi:

      Filesystem      Size  Used Avail Use% Mounted on

      rootfs          3.7G  2.4G  1.2G  68% /

      /dev/root      3.7G  2.4G  1.2G  68% /

      devtmpfs        112M    0  112M  0% /dev

      tmpfs            24M  228K  23M  1% /run

      tmpfs          5.0M    0  5.0M  0% /run/lock

      tmpfs            47M    0  47M  0% /run/shm

      /dev/mmcblk0p1  56M  9.7M  47M  18% /boot



        • 1. Re: Root size limit...
          JPMontero_Intel

          Hi DaveInDurban,

           

          Actually this is fixed in release 2, now it has 1.4G in /dev/root (see image below). If you are currently using Release 2 and your board is not repartitioned I’d suggest you to try the flashall method. Let me know if this helps.

           

          Partition.PNG

           

          Regards,

          JPMontero_Intel

          • 2. Re: Root size limit...
            DaveInDurban

            Thanks JPMontero_Intel. Can you point me to instructions for the flashall method using Windows 8.1 x64? I've searched the forums and only found old posts that say it doesn't work with Windows or there are problems running it from Windows, etc.. If there is anything I need to do to change the partition size before flashing, let me know.

             

            When you say release 2, do you mean the board or the firmware? How do I find out the release? I'm not near the board now, but I bought it a week ago, and downloaded the firmware that was dated January 31st (I think). It had come with an August 2014 version.

            • 3. Re: Root size limit...
              JPMontero_Intel

              You can download the release in the following site, it is displayed as Yocto complete image. Also in this message vjou provided this link for a pre-compiled version of dfu-util for Windows. Please follow these steps:

               

              1. Download Edison Yocto complete image.
              2. Extract the content into a folder.
              3. Download dfu-util.
              4. Copy the dfu-util.exe in the same folder you extracted the Yocto image.
              5. Open cmd and go to the directory of the Yocto image and type flashall.bat

               

              At this moment you should see a message that says "Please plug and reboot the board", once you rebooted the board it should start flashing. I just tested it and works just fine, but in case you get an error let us know. I hope this helps, let me know if it works for you.

               

              Regards,
              JPMontero_Intel

              1 of 1 people found this helpful
              • 4. Re: Root size limit...
                DaveInDurban

                Thanks, that worked for me.

                 

                Poky (Yocto Project Reference Distro) 1.6.1 edison ttyMFD2

                 

                edison login: root

                root@edison:~# configure_edison --version

                120

                root@edison:~# df -h

                Filesystem                Size      Used Available Use% Mounted on

                /dev/root                 1.4G    364.2M    982.9M  27% /

                devtmpfs                479.9M         0    479.9M   0% /dev

                tmpfs                   480.2M         0    480.2M   0% /dev/shm

                tmpfs                   480.2M    504.0K    479.7M   0% /run

                tmpfs                   480.2M         0    480.2M   0% /sys/fs/cgroup

                systemd-1                 5.7M      5.3M    462.0K  92% /boot

                tmpfs                   480.2M      4.0K    480.2M   0% /tmp

                tmpfs                   480.2M         0    480.2M   0% /var/volatile

                /dev/mmcblk0p7            5.7M      5.3M    462.0K  92% /boot

                /dev/mmcblk0p5         1003.0K     19.0K    913.0K   2% /factory

                systemd-1                 1.3G      2.0M      1.3G   0% /home

                /dev/mmcblk0p10           1.3G      2.0M      1.3G   0% /home

                root@edison:~#

                • 5. Re: Root size limit...
                  JPMontero_Intel

                  That’s great, I’m glad to hear it worked for you.

                   

                  Regards,
                  JPMontero_Intel

                  • 6. Re: Root size limit...
                    pekbo

                    In my case I've got Edison attached to Windows but there is no ota mounted under Windows.  This rules out flashall.bat.

                    Even if I could get the ota to mount under Windows, the moment dfu-util asks that I power cycle the Edison I lose the

                    drive and the entire process goes kaput.

                     

                    I can't seem to get myself out of this one... any help would be appreciated.

                     

                    Thanks!

                    • 7. Re: Root size limit...
                      JPMontero_Intel

                      Hi pekbo,

                       

                      You don’t have access to the Edison drive, right? So you cannot do the reboot ota method, but the flashall method as long as the USB cable is recognized by the computer you can try flashall, this method does not requires access to the Edison drive.

                       

                      Regards,
                      JPMontero_Intel

                      • 8. Re: Root size limit...
                        DangerousTim

                        Where did you get release 2?

                        • 9. Re: Root size limit...
                          JPMontero_Intel

                          Hi DangerousTim,

                           

                          You can get release 2 from here, right where it says Yocto complete image.

                           

                          Regards,
                          JPMontero_Intel