5 Replies Latest reply on Nov 19, 2016 3:05 AM by Bennett

    Setting time - NTP synchronization issues when using a static IP

    eco_bach

      I have an Edison which gives me the correct time when using the default DHCP settings to obtain the IP.

      However, after using connmanctl to set a static IP I can't seem to connect with any timeservers.

      Is there a solution to this?

       

      $connmanctl config <service> --ipv4 manual <ip address> <netmask> <gateway>

       

       

      Also read this long and informative  thread

       

      Setting time zone and synchronizing time with time server on Edison

       

      When I enter

      $systemctl status systemd-timesyncd

       

      I notice that the service is active yet the Status is "Idle"

       

      systemd-timesyncd.service - Network Time Synchronization

        Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled)

        Active: active (running) since Mon 2015-03-09 20:07:57 UTC; 30min ago

          Docs: man:systemd-timesyncd.service(8)

      Main PID: 156 (systemd-timesyn)

        Status: "Idle."

        CGroup: /system.slice/systemd-timesyncd.service

                └─156 /lib/systemd/systemd-timesyncd

       

      Jan 01 00:00:12 tesla systemd-timesyncd[156]: System clock time unset or jumped backwards, restoring fr... UTC

      Mar 09 20:07:57 tesla systemd[1]: Started Network Time Synchronization.

      Mar 09 20:08:02 tesla systemd-timesyncd[156]: Network configuration changed, trying to establish connection.

      Mar 09 20:08:03 tesla systemd-timesyncd[156]: Network configuration changed, trying to establish connection.

      Hint: Some lines were ellipsized, use -l to show in full.

       

       

       

      And when I enter

      $timedatectl status

       

      I notice that NTP is not synchronized

       

      Local time: Mon 2015-03-09 20:31:47 UTC

        Universal time: Mon 2015-03-09 20:31:47 UTC

              RTC time: Sat 2000-01-01 00:24:02

             Time zone: Universal (UTC, +0000)

           NTP enabled: yes

      NTP synchronized: no

      RTC in local TZ: no

            DST active: n/a

       

       

      Anyone suggest some next steps?

      My goal is simply to set the date and time, and optionally the time zone