1 2 Previous Next 15 Replies Latest reply on Apr 14, 2015 6:32 PM by CMata_Intel

    Where do I start?

    cgkades

      Hello All,

       

      I'm trying to get going with the Galileo board, but am running into some confusion. From what I can figure out, there are two downloadable images. One named SDCard and the other named iotdk-galileo. I was doing some testing in qemu since I'm waiting on the console cable to arrive from amazon, and I was able to get some programs to run in the downloadable image from yocto (https://www.yoctoproject.org/docs/current/yocto-project-qs/yocto-project-qs.html). After getting that working, I tried to use the image from the SDCard download and was unable to get it to run.  Is that an ok test env? Is there a virtual env anyone recomends? Is there any way to build newer versions of yocto for the Galileo so I can add more features (like rpm)?

       

      I see that there is Intel® Galileo Boards and Kits — Software Downloads, but there isn't much explanation as to what each section is used for.

       

      Thanks for any help,

      Brett

        • 1. Re: Where do I start?
          CMata_Intel

          Hi cgkades

           

          The SDcard image is uclibc and the iotdk-galileo is eglibc. Take a look at the BSP, I think you will find very helpful information about the SDK (Section 6) and about how to add other packages (Section 2)

           

          Regards;

          CMata

          • 2. Re: Where do I start?
            cgkades

            Thanks for the reply! I'll read that tonight

            • 3. Re: Where do I start?
              cgkades

              Actually... i started reading it now and already found a gap in the docs... where do you get meta-clanton*.tar.gz from?

               

              "First, open a new terminal session, extract the yocto layer, and run the setup.sh script to download the external sources required for the yocto build: # tar -xvf meta-clanton*.tar.gz"

              • 4. Re: Where do I start?
                cgkades

                I just can't get this to work with that doc. I finally found the meta-clanton* in some other obscure doc. But now none of the build stuff works in section 4.

                 

                source poky/oe-init-build-env yocto_build doesn't work.. you have to go into repo-ext first.. then when you do the source and try to build you get an error, ERROR: Nothing PROVIDES 'image-full'

                 

                Anyone have links to doc's that actually work?

                • 5. Re: Where do I start?
                  CMata_Intel

                  Hi cgkades

                   

                  Did you use this link to download the file = Intel® Download Center ?

                  Which OS are you using and did you install all the dependencies?

                  Could you post a screenshot of the message you receive after trying source poky/oe-init-build-env yocto_build ?

                   

                  Regards;

                  CMata

                  • 6. Re: Where do I start?
                    cgkades

                    I'm using Fedora 21. I installed all the dependencies as outlined in a yocto doc, which include the small incomplete list in the Galileo doc. I can post a screenshot, or copy/paste the errors if necessary, but it looks like after downloading the BSP and exacting it, then extracting the meta-clanton*.tar.gz archive, you get the following folder structure (shortened for clarity):

                     

                    meta-clanton_v1.1.0-dirty

                         repo-ext

                              poky

                     

                    Inside of the meta-clanton_v1.1.0-dirty dir is a file iot-devkit-init-build-env, which, if I source it with source iot-devkit-init-build-env yocto_build, I then get the option to do image-full. If I do bitbake image-full I see

                     

                    Build Configuration:

                    BB_VERSION        = "1.22.0"

                    BUILD_SYS         = "x86_64-linux"

                    NATIVELSBSTRING   = "Fedora-21"

                    TARGET_SYS        = "i586-poky-linux"

                    MACHINE           = "quark"

                    DISTRO            = "iot-devkit"

                    DISTRO_VERSION    = "1.1"

                    TUNE_FEATURES     = "m32 i586"

                    TARGET_FPU        = ""

                    meta             

                    meta-iot-devkit  

                    meta-yocto       

                    meta-quark-bsp   

                    meta-galileo      = "master:d4fb843ad628814a09954514e120688c6b5ed736"

                     

                    If I go into repo-ext and do source poky/oe-init-build-env yocto_build i see what looks to be the standard yocto targets as if i only downloaded yocto:

                     

                    ### Shell environment set up for builds. ###

                     

                    You can now run 'bitbake <target>'

                     

                    Common targets are:

                        core-image-minimal

                        core-image-sato

                        meta-toolchain

                        adt-installer

                        meta-ide-support

                     

                    You can also run generated qemu images with a command like 'runqemu qemux86'

                    • 7. Re: Where do I start?
                      CMata_Intel

                      Hi cgkades

                       

                      The supported Linux Distributions for Yocto are these ones and the validated for Intel is Ubuntu 12.04.

                      Which other dependencies did you need that were not in the document?

                      I suggest you to use these files and not the 1.1.0 version you are using.

                      What is the error after bitbake? Could you post the log you are receiving?

                       

                      Regards;

                      CMata

                      • 8. Re: Where do I start?
                        cgkades

                        Alright, I'll set up an Ubuntu VM instead, though it really shouldn't matter. Also, the link in "these files" goes to a "Page Not Found"

                        • 9. Re: Where do I start?
                          CMata_Intel

                          Hi cgkades

                           

                          I've just tested the link and worked in different browsers, I'm not sure why it doesn't work with you. Try to enter in here: Intel® Download Center and download the file named as: BSP_Sources_and_Docs_for_Intel_Quark_v1.0.1.zip . Let me know if that link works for you, if not try with a different browser.

                           

                          Regards;

                          CMata

                          • 10. Re: Where do I start?
                            cgkades

                            Here is the failure:

                             

                            WARNING: Failed to fetch URL git://github.com/vathpela/grub-fedora.git, attempting MIRRORS if available

                            ERROR: Fetcher failure: Fetch command failed with exit code 128, output:

                            Cloning into bare repository '/home/cgkades/galileo/Galileo-Runtime-1.0.4/meta-clanton_v1.0.1/yocto_build/downloads/git2/github.com.vathpela.grub-fedora.git'...

                             

                             

                            fatal: remote error:

                              Repository not found.

                             

                             

                            ERROR: Function failed: Fetcher failure for URL: 'git://github.com/vathpela/grub-fedora.git'. Unable to fetch URL from any source.

                            ERROR: Logfile of failure stored in: /home/cgkades/galileo/Galileo-Runtime-1.0.4/meta-clanton_v1.0.1/yocto_build/tmp/work/i586-poky-linux-uclibc/grub/0.97+gitAUTOINC+5775f32a6268dead6939d01cbe72f23972f6d3c0-r0/temp/log.do_fetch.5703

                            ERROR: Task 72 (/home/cgkades/galileo/Galileo-Runtime-1.0.4/meta-clanton_v1.0.1/meta-clanton-bsp/recipes-bsp/grub/grub_0.97.bb, do_fetch) failed with exit code '1'

                            NOTE: Tasks Summary: Attempted 1172 tasks of which 185 didn't need to be rerun and 1 failed.

                            Waiting for 0 running tasks to finish:

                             

                             

                            Summary: 1 task failed:

                            /home/cgkades/galileo/Galileo-Runtime-1.0.4/meta-clanton_v1.0.1/meta-clanton-bsp/recipes-bsp/grub/grub_0.97.bb, do_fetch

                            • 11. Re: Where do I start?
                              CMata_Intel

                              Hi cgkades

                               

                              Are you following the BSP Guide step by step or are you adding new recipes and packages?  The fetch error you are having seems to be related to this link git://github.com/vathpela/grub-fedora.git if you go to this github you will see that the website it's down. Also, could you attach the log file you are receiving after the building process fails?

                               

                              Regards;

                              CMata

                              • 12. Re: Where do I start?
                                xbolshe

                                Hi, ,

                                 

                                you need to change URL to git://github.com/vathpela/grub2-fedora.git

                                 

                                Best regards,

                                xbolshe

                                • 13. Re: Where do I start?
                                  xbolshe

                                  I have the following:

                                  galileo110.jpg

                                   

                                  <your_root>/meta-clanton_v1.1.0-dirty$ source ./iot-devkit-init-build-env yocto_build

                                  <your_root>/meta-clanton_v1.1.0-dirty/yocto_buildbitbake image-full

                                  • 14. Re: Where do I start?
                                    cgkades

                                    The problem is that intel supports yocto, instead of a useable OS, like say.... ubuntu, or debian.

                                    1 2 Previous Next