3 Replies Latest reply on Mar 19, 2015 10:46 PM by phixion

    Intel RST "Platform not supported"

    phixion

      Hello,

       

      Just to make you aware that the last few versions of Intel Rapid Storage Technology no longer work on my PC.


      When attempting to install I get the message "Platform not supported". I have to install an older version - 13.1.0.1058

       

      I spoke to a few friends about it over the weekend and they too see the same problem, only they have to use even older versions to get it to work.

       

      Am I missing something here? Is there a simple explanation or is something wrong with the installer?

       

      Also, we have been debating whether you need Intel RST drivers if you don't use RAID but only AHCI, can anyone give an answer on this please?

       

      Cheers