5 Replies Latest reply on Aug 22, 2015 8:26 AM by 75fcc

    NUC515RYH Graphics and Linux

    malch

      I have just received a new NUC515RYH. I installed 4GB RAM and a SSD without any problem and can boot from a USB thumb drive.

       

      I started with Lubuntu 14.10 x64. It boots up to the desktop but many elements are not painted. In some cases, an element like an icon will be painted when I mouse over that area. I can launch an app but what is shown looks like a frame with transparent content. Again, mousing over will cause SOME elements (e.g. buttons) to be painted. But it's basically unusable.

       

      In order to solve this, I have taken the following steps without success:

       

      * Checked BIOS version. It matches the latest available from the Intel Download Center.

      * Reset the BIOS to default settings.

      * Checked my USB thumb drive. It boots fine on my i7/HD4000 laptop.

      * Checked the HDMI and DisplayPort video outputs on the NUC.

       

      Next I tried Linux Mint 17.1 Cinnamon x64 and that worked a little better but still gobs of screen painting issues. Linux Mint 17.1 Xfce x64 booted to a black screen (worse).

       

      I'm guessing we have a problem with the X drivers and HD 6000 graphics but do not know what to do about it.

       

      Any help greatly appreciated.

        • 1. Re: NUC515RYH Graphics and Linux
          kevin_intel

          Hello malch,

           

          Thank you for letting us know about this.

           

          We have received reports and we are currently working on this. We have reproduced the problem from our side and we are investigating this problem.

           

          Since this is a very brand new product, I recommend you checking the website for a future BIOS update that may contain a fix for it.

           

          Kevin M

          • 2. Re: NUC515RYH Graphics and Linux
            kominato

            same problem right now .. I have a nuc5i5ryk no success to install ubuntu 14.04 14.10

            it loads grub then loads the installer but the graphics are broken .. windows only have bars, no text, no menus, no buttons at all ... when I pass the mouse inside windows suddenly buttons appear etc

            ... but it seams that the beta ubuntu 15.04 works fine

            • 3. Re: NUC515RYH Graphics and Linux
              malch

              Kevin: Thank you for the update. Good to know you guys have reproduced the problem and are working on it.

               

              kominato: Wheeeee. I did get Mint 17.1 installed and working in software rendering mode but that kinda sucks. I grabbed lubuntu 15.04 and the LiveCD booted up with clean graphics. So I installed it and that seems to be running okay too. Now I can move forwards with my little HTPC project. You made my day so thank you very much indeed.

              • 4. Re: NUC515RYH Graphics and Linux
                rgn

                Hi malch 

                After some testing an issue with the Linux Kernel version was found. I tried different Linux* versions with Kernel 3.13 and in all configurations de the same behavior was exhibited.

                 

                 

                Tests made with Ubuntu and ArchLinux based in Kernel 3.18 worked ok.

                 

                For now, I would recommend to update Kernel to 3.18 in a different integration and build a new installation distribution. 

                1 of 1 people found this helpful
                • 5. Re: NUC515RYH Graphics and Linux
                  75fcc

                  Also Linux Mint 17.02 installs and runs just fine.