5 Replies Latest reply on Mar 28, 2016 11:38 AM by RzR

    The ultimate guide for ubuntu headless server on DN2820FYK

    Bacchi

      After days of struggling this is how I came up with a functioning solution of a headless ubuntu server 14.04.2 on a NUC DN2820FYK.

      Hope this saves some pain to someone

       

      1. BIOS

       

      This is where the big problems are because not every intel bios supports headless boot, with some bios it won't boot if there is no video attached. I have not tested every bios but I can tell you that the version 0034 is working while the 0048 (the last available now) is not. If you have tested other bios write it in the comment, so I can update the list.

       

      WORKING BIOS

      0034

       

      NOT WORKING BIOS

      0048

       

      So the first thing to do is to upgrade or downgrade the bios to a working version.

      Download it from here:

      http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProdId=3782

       

      Here is the procedures, I personally used the F7 BIOS Flash update

      http://www.intel.com/support/motherboards/desktop/sb/CS-034499.htm

       

      Important note: If the standard procedure doesn't work (as in my case downgrading from 0048 to 0034) you have to do a BIOS Recovery Update

      http://www.intel.com/support/motherboards/desktop/sb/CS-034524.htm

       

      If you have problem booting after the bios upgrade, clear the CMOS

      http://www.intel.com/support/motherboards/desktop/sb/CS-034634.htm

       

       

      2. BIOS SETUP

       

      Enter the bios setup with F2 and first of all load the default configuration with F9

      In the boot configuration DISABLE UEFI BOOT and ENABLE LEGACY BOOT

      Other default settings left unchanged.

       

       

      3. LINUX INSTALLATION

       

      Nothing special about the linux installation, it will create 2 partitions (ext and swap) and not 3 as with EFI boot.

      The only strange thing was during the installation of grub because by default it is installed on /dev/sda but during the installation that was the usb key I was installing from so I manually had to change the path to /dev/sdb which was the hard disk.

       

       

      Hope this helps!

        • 1. Re: The ultimate guide for ubuntu headless server on DN2820FYK
          allan_intel

          I am glad you have shared this information. I am sure it will help a lot.

           

          Allan.

          • 2. Re: The ultimate guide for ubuntu headless server on DN2820FYK
            Tom_Boctou

            Thanks for the info.

             

            Can anyone explain why switching to legacy boot is necessary?

             

            I'm putting together a custom Ubuntu installation image for the DN2820FYKH, and I'm having trouble getting an install process that will work on all of our NUCs.

             

            The problem I'm seeing is that an install done on one NUC may or may not work if I swap the disk into another - sometimes I get the "no bootable disk found" message (I don't remember the exact wording).  I need to have one image that will work on all the NUCs so I can do an install onto one disk and run it through a disk duplicator.  I've got some NUCs with BIOS version 015 and some with 032, I'm upgrading them all to 047 but the 015's need two installs to get both the BIOS and the BIOS config installed, so there's a chance that something's not getting updated correctly.  I'm trying to come up with a matrix of what works and what doesn't, but it's a confusing and time consuming process, so I'm hoping that someone else has fought this battle already.

             

            I need UEFI boot, so I can't just switch to legacy boot.

            • 3. Re: The ultimate guide for ubuntu headless server on DN2820FYK
              GFJames

              Encouraged by this thread, I went through all available BIOS versions on the support download page for the DE3815TYKHE (D3815TYBE). Currently, they are 19, 24, 30, 32, 34, 36, 37, 39, 41. I did not test 19 as I could not access the internal eMMC using it. I used the iflash from DOS method of flashing as the others I tried (update from boot screen, update/recover from hold-power-button-four-seconds screen, and recover by removing BIOS security jumper) proved unreliable and failed for no apparent reasons in different stages of the process.

               

              Of all tested versions, only version 24 of the DE3815TYKHE BIOS allowed me to boot without a display connected, and to connect a VGA display to the NUC after the boot and get a picture, if needed. The only change from the default BIOS settings I had to make was to enable the eMMC boot device (and set OS selection to Linux). I did not disable UEFI.

               

              The BIOS versions for the DE3815TYKHE and DN2880FYKH released after the working versions (30 and 37, respectively) were both released on the same date: 2014-07-10. If this issue affects other NUCs as well, I would imagine trying BIOS versions prior to this date would be a good place to start.

               

              So headless boot was working but something Intel did in July of last year broke it.

               

              To be clear, this is a non-GUI Debian 7.8 installation and the issue is booting without a display connected. As far as I know, then, this issue is not related to the remote desktop/VNC problems that one can't help but notice when searching for solutions in this forum. But perhaps in attempting to solve that problem, Intel changed something that broke something else.

               

              The issue is not resolved but at least I now have a workaround. Thanks, thread starter. Intel, you're up.

               

              (As an aside, I am disappointed in Intel. I've spent many hours on this ridiculous issue, which is exactly what I expected not to have to do with an Intel product and why I went with Intel rather than Gigabyte or another competitor with similar but cheaper products.)

              • 4. Re: The ultimate guide for ubuntu headless server on DN2820FYK
                Piotr_L

                Using DN2820FYKH, with the last bios 0048.

                For me it was enough to check the Legacy Boot - without unchecking UEFI Boot, and everything boots without monitor attached. It did not work without Legacy boot checked.

                Installed Debian Wheezy for UEFI Boot.

                Bios 0034 also worked with the same condition.

                Thanks for your note!

                • 5. Re: The ultimate guide for ubuntu headless server on DN2820FYK
                  RzR

                  As a DE3815TYKHE owner,  I am facing troubles since latest BIOS upgrade too, is it safe to downgrade BIOS to 24 (link welcome too) ?

                   

                  --

                  https://communities.intel.com/docs/DOC-25132