7 Replies Latest reply on Aug 21, 2015 7:43 PM by wq7278

    ECONNREFUSED from XDK

    lectroidmarc

      Since updating to WW05 I've been getting an ECONNREFUSED from my edison when trying to connect with XDK.  The xdk-daemon is running and my IP is in the whitelist, however, it appears that the xdk-daemon is attached to localhost and not any other interface.  This would explain the problem , but I'm not sure the best way to fix it.  Any thoughts?

       

      Marc

        • 1. Re: ECONNREFUSED from XDK
          massca

          Hi Marc,

          I solved this problem selecting "Add manual connection", flag the "use secure connection" check box, and typing user name and password.

           

          I think that the new xdk-daemon doesn't accept anonymous connections.

          • 2. Re: ECONNREFUSED from XDK
            lectroidmarc

            Oh, of course, that makes perfect sense.

            • 3. Re: ECONNREFUSED from XDK
              intel_dan

              This is bug in the Intel XDK IoT Edition, and it will be fixed in the next XDK release. Below is the workaround:

               

              Issue:

              "ECONNREFUSED" message when trying to connect to an iot device from Intel XDK IoT Edition (release 0128) to a device running XDK daemon 0.0.26 or greater.

               

              Workaround (2 methods):


              Method #1


              1: Select "Add Manual Connection" from the device drop down

              Screen Shot 2015-02-17 at 4.10.21 PM.png

              2: Select/check the "Use secure connection" checkbox. Then click 'Connect' (clicking 'Connect' will save the 'secure connection' preference, and allow normal connections on future attempts)

              Note: The connection may fail if the wrong ip was entered, this is ok. The 'Use secure connection' option will now be the default (and subsequent connections that are initiated by selecting a device from the device list will succeed!)

              Screen Shot 2015-02-17 at 4.11.07 PM.png

               

              Method #2

               

              1: Exit the XDK, then open the Intel XDK IoT Edition 'global-settings' file. The “global-settings” file located in the following path:

               

              Windows: %localappdata%/XDK-IoT/global-settings.xdk

              Linux: ~/.config/XDK-IoT/global-settings.xdk

              Mac: ~/Library/Application Support/XDK-IoT/global-settings.xdk

               

              2:  In the "iot-tab" section of the file

                "iot-tab": {

                  "user": "root",

                  "keyFilePath": "",

                 "secureConnection": false,

                  "useKeys": false,

                  "suppressVersionAlert": false,

                  "promptSync": true,

                  "manualConnectAddress": "192.168.2.15:58888"

                }

              change the "secureConnection" setting/line from 'false' to 'true'

              Ex: change from: "secureConnection": false   to:  "secureConnection": true


              3: Restart the Intel XDK IoT Edition

              • 4. Re: ECONNREFUSED from XDK
                arunpatro

                I am not getting a checkbox to select SecureConnection, I only have Use SSH keys

                iot.png

                • 5. Re: ECONNREFUSED from XDK
                  intel_dan

                  The option to use and unsecure connection has been removed from the Intel XDK IoT Edition. The latest versions of the Intel XDK IoT Edition are now setup to always establish a secure connection to IoT Device via SSH Tunneling.

                  • 6. Re: ECONNREFUSED from XDK
                    cincoutprabu

                    I was able to solve the ECONNREFUSED issue by changing the password using "configure_edison --password" command in putty. Looks like the "Use secure connection" checkbox has been removed from Add Manual Connection window, but after changing the password, I'm able to connect by selecting the device IP address from "IoT Device" dropdown and entering the credentials (root as username and new password).

                    • 7. Re: ECONNREFUSED from XDK
                      wq7278

                      Hi, I can confirm set a password for root fix this issue;

                       

                      Looks like SSH and Wifi is not enbled until you get the password set up.

                                                                                                                                      

                      First-time root password setup complete. Enabling SSH on WiFi interface.                                                                                                   

                      The device password has been changed.