3 Replies Latest reply on Feb 24, 2015 1:56 PM by Intel_Alvarado

    Problem modifying u-boot (start16.S)

    gsrebro

      Hello

       

      I'm having a problem trying to modify the u-boot start16.S file. As this file doesn't change in /edison-src/device-software/meta-edison-distro/recipes-bsp/u-boot/files/upstream_to_edison.patch file I create a new one in /edison-src/device-software/meta-edison-distro/recipes-bsp/u-boot/files/start16.S and added the following line in /edison-src/device-software/meta-edison-distro/recipes-bsp/u-boot/u-boot-internal.inc: SRC_URI += "file://start16.S"

       

      The problem is that start16.S doesn't change at all.

       

      What method do you recommend to change it?

       

      Thanks

       

       

      Gabriel Srebro

        • 1. Re: Problem modifying u-boot (start16.S)
          Intel_Alvarado

          HI gsrebro,

           

          According to the yocto reference manual http://www.yoctoproject.org/docs/current/ref-manual/ref-manual.html :

           

          If you want the build system to pick up files specified through a SRC_URI statement from your append file, you need to be sure to extend the FILESPATH variable by also using the FILESEXTRAPATHS variable from within your append file.

           

          Have you already tried this?

           

          Regards

          Sergio

          • 2. Re: Problem modifying u-boot (start16.S)
            gsrebro

            Thanks Sergio for your response.

             

            Yes, I've already tried that. I'll copy u-boot-internal.inc:

            PV = "2014.04-1"

            S = "${WORKDIR}/git"

            FILESEXTRAPATHS_prepend := "${EDISONREPO_TOP_DIR}/edison-src/device-software/meta-edison-distro/recipes-bsp/u-boot/files/"

            PACKAGE_ARCH = "${MACHINE_ARCH}"

            SRC_URI = "git://git.denx.de/u-boot.git;branch=master"

            SRC_URI += "file://upstream_to_edison.patch"

            SRC_URI += "file://${MACHINE}.env"

            SRC_URI += "file://target_env/*.env"

            SRC_URI += "file://start16.S"

            SRCREV = "dda0dbfc69f3d560c87f5be85f127ed862ea6721"

             

            The thig is that we need to modify start16.S and, instead of add lines in upstream_to_edison.patch, we make a new one. We only need to add 4 lines to check if this method works and web can't make it. The lines are movl's:

             

            start16:

                    /* Set the Cold Boot / Hard Reset flag */

               movl      0xa5a5a5a5, %ebx

               movl      0xa5a5a5a5, %ebx

               movl      0xa5a5a5a5, %ebx

               movl      0xa5a5a5a5, %ebx

               movl $GD_FLG_COLD_BOOT, %ebx

             

             

            How do you recommend me to change this file?

             

            Thanks in advance

             

             

            Gabriel Srebro

            • 3. Re: Problem modifying u-boot (start16.S)
              Intel_Alvarado

              Hi gsrebro,

               

              Did you make sure that the new file created is included in the recipe? You should add the name of this recipe to the bblayers.

               

              Regards

              Sergio