4 Replies Latest reply on Feb 17, 2015 12:26 PM by CMata_Intel

    Problem for New SW(Edison R2 Beta SW)

    Jacen

      Hi Evertone

      i just tried the new SW (Edison R2 Beta SW),

      The WIFI for Arduino part has problem.

      If you try in Arduino IDE by Intel, File->Example->WIFI->ConnectWithWPA, this one does not work which is no problem in previous SW Version.

       

      BTW ,Could some one give the code that is  same function for WIFI connect WIFI scan but without Arduino library.

       

      Thanks

       

      Jacen

        • 1. Re: Problem for New SW(Edison R2 Beta SW)
          CMata_Intel

          Hi Jacen

           

          I've just tested the ConnectWithWPA sketch with Release 1 and Release 2, and yes the same outcome. I will keep trying and let you know a fix or workaround to make it work.

          About the function for WiFi, I'm not sure which function are you trying to get. Do you want to use a code to run it in Serial Console, or do you want to connect your board to your network using the Arduino-IDE and system("") calls ?

           

          Regards;

          Carlos

          • 2. Re: Problem for New SW(Edison R2 Beta SW)
            CMata_Intel

            Hi Jacen

             

            The first time when I ran the sketch on R2 I got in the Serial Monitor something like:

            Attempting to connect to WPA SSID: MyWiFi1

            Attempting to connect to WPA SSID: MyWiFi1

            Attempting to connect to WPA SSID: MyWiFi1

            Attempting to connect to WPA SSID: MyWiFi1

             

            After that I ran it using the R1 and it worked fine.Now, I'm back to R2 and I ran configure_edison --setup to set my WiFi, name and password, after that I ran again the sketch and now it's working.

            Attempting to connect to WPA SSID: MyWiFi1

            You're connected to the networkSSID: MyWiFi1

            BSSID: XX:XX:XX:XX:XX:XX

            signal strength (RSSI):-57

            I also tried to connect the board to another WiFi using the configure_edison --w. I was connected to MyWiFi2 and after that I ran again the sketch to connect the board to MyWifi1 and it worked again.

            Could you check the status of the network you are using? the issue could be there.

            What happens with other sketches? What happens with the ScanNetworks sketch?


            Regards;

            CMata

            • 3. Re: Problem for New SW(Edison R2 Beta SW)
              Jacen

              Hi CMata_Intel

              Yeah,that way works ,but  i think that way is actually using the code in configure_edsion to connect WIFI. the sketch still not works ,just because the Edison already been connect by configure_edison so that when running the sketch is could connect to WIFI.


              That 's why i am asking to the native code which can do the same function as Aduino library did in WIFI part, which i could compile the code in eclipse directly.


              Thanks Very much


              Jacen

               

              • 4. Re: Problem for New SW(Edison R2 Beta SW)
                CMata_Intel

                Hi Jacen

                 

                Take a look at this document (section 9.2) I think it will help you to create the routine that you need.

                If you want to use the same process that the Arduino example does, you could check the WiFi libraries in:

                     C:\arduino-1.5.3-Intel.1.0.4\hardware\arduino\edison\libraries

                In the document you also will see the way to start the service using system-Linux commands.

                 

                Regards;

                CMata