1 2 Previous Next 15 Replies Latest reply on Mar 10, 2015 6:39 PM by CMata_Intel

    _exports_Pwm error, working with a servo

    MattGross

      Hi All, I'm setting up a servo with edison & ran into an error message that I couldn't figure out.


      The first time I plugged the servo into pin 9 it worked, and subsequently I started seeing this error message whenever I ran my script.


      Error: Illegal arguments for construction of _exports_Pwm
          at Adaptor.pwmWrite (/home/root/node_modules/cylon-intel-iot/lib/adaptor.js:206:11)
          at Adaptor.servoWrite (/home/root/node_modules/cylon-intel-iot/lib/adaptor.js:185:8)
          at Servo.angle (/home/root/node_modules/cylon-gpio/lib/servo.js:96:19)
          at null.<anonymous> (/home/root/testing-servo.js:24:16)
          at wrapper [as _onTimeout] (timers.js:258:14)

          at Timer.listOnTimeout [as ontimeout] (timers.js:110:15)


      If I plug the servo into other pins (tried 3, 4, & 6), it throws the same error, so my most basic understanding of the error is that I'm using a pin improperly.


      Any advice? What should I be looking at?


      Thanks!


      Matt

        1 2 Previous Next