4 Replies Latest reply on May 20, 2015 2:30 AM by MarkOg

    Edison damaged by servo motor?

    X_Y

      I was trying to connect Edison to a standard servo, the board restarted a few times after the servo moved. I figured the power was not enough, so I plugged in the 15V power supply to Edison. The servo worked fine afterwards, however it started behave weirdly afterwards. At first I could still upload simple sketches like blink or bare minimum, but after a few attempts nothing can be uploaded. Following is the debug message given:

       

      ...

      Bytes Sent:  70656/  71524   BPS:937329   ETA 00:00  Retry 0: Got ZCAN

       

       

      Transfer incomplete

       

       

      #mv the downloaded file to /sketch/sketch.elf

      Moving downloaded file to /sketch/sketch.elf on target

      target_download_name="${host_file_name##*/}"

      echo "Moving downloaded file to /sketch/sketch.elf on target"

      #$fixed_path/lsz.exe --escape -c "cp sketch /sketch/sketch.elf" <> $tty_port_id 1>&0

      $fixed_path/lsz.exe --escape -c "mv $target_download_name /sketch/sketch.elf; chmod +x /sketch/sketch.elf" <> $tty_port_id 1>&0

      Retry 0: Got TIMEOUT

      Retry 0: Got ZCAN

       

       

      Transfer incomplete

       

      At a certain time when I was uploading, my windows 8 machine went into a blue screen of death, which never happened before.

       

      However the Edison is not totally damaged, I can still ssh to the board.

       

      Have anybody seen a similar situation?

        • 1. Re: Edison damaged by servo motor?
          Intel_Peter

          Hello X_Y,

           

          First, are you sure you used a 15v power supply?

          Now, there are a few things we could check to see if your board is still functional. If you connect the Edison to both USB ports, are you able to see both ports in the device manager?

          Are able to read the Edison's flash drive from Windows Explorer?

          Are you able to access the Linux shell?

           

          Peter.

          • 2. Re: Edison damaged by servo motor?
            CMata_Intel

            Hi X_Y

             

            Were you able to use your Edison board again?

             

            Regards;

            CMata

            • 3. Re: Edison damaged by servo motor?
              X_Y

              @Intel_Peter those are all functional, the hardware seems to be ok. But the Arduino sketch uploading mechanism seems to be irreversibly damaged, I tried with a few computers and all get the same result. Eventually I had to reflash the firmware with reboot ota, and the board is functional again.

              • 4. Re: Edison damaged by servo motor?
                MarkOg

                You might just have run out of space on your rootfs. Every time you upload a sketch, data gets logged at /var/log/journal. The logs are persistent, so if you're already low on space your free space can get soaked up. Check the available size with df -h, you'll be interested in /dev/root.

                 

                Remove the logs manually and you'll be ready to go again.