1 Reply Latest reply on Feb 4, 2015 8:05 AM by joe_intel

    Upon BIOS update IRST sees previously functional RAID1 fine, but Win7 indicates drive not initialized?

    Duliskov

      I updated ASUS Mobo P9X79 BIOS from 3305 to 4701. The previously created RAID1 (mirror), that was created via CTRL-I during boot and was recognized and worked fine under Win7 64 bit Ultimate - suddenly disappeared after this BIOS update and is marked "not initialized" in Win7. The Win7 Disk Manager only shows one disk for the RAID as you would expect. IRST running under Win7 shows the status of RAID as NORMAL. I ran a Verify, which found about a thousand errors in the first few seconds, corrected them all and subsequently did not find anything else wrong during the next several hours. The drives in RAID1 were initialized originally as GPT as they are 4TB each. The system boots from a SSD, the RAID1 is just a data drive and has no boot partition on it.

       

      The RAID is full of data that I don't want to lose.

       

      I tried to set mobo SATA to AHCI - the Win7 Disk manager showed two identical "not initialized" HDDs and Intel Controller disappeared from under Storage Controllers in Device Manager (again as you would expect).

       

      I tried restoring the old BIOS, but ASUS does not want to downgrade, says outdated BIOS version and firmware was changed and other nonsense like that, and refuses to write 3305 BIOS to mobo.

       

      Based on the errors corrected by verify under IRST I am under impression that GPT tables somehow got corrupted.

       

      Questions:

      1. I believe unlinking the drives (breaking the RAID1) via CTRL-I during boot will not fix this issue, any experience contrary?

      2. Is there a way to recreate the GPT file structure that is logically behind the IRST?

      3. Any software that might go through the disk content and rebuild the file structure?

      4. Would another operating system (which?) recognize the drives and be able to use them? I am willing to experiment with live-CDs. Anybody knows of a live-CD with IRST drivers?

      5. ANY OTHER IDEA? Please! I spent a week trying to recover from this disaster without any progress!

       

      Thank you in advance.

        • 1. Re: Upon BIOS update IRST sees previously functional RAID1 fine, but Win7 indicates drive not initialized?
          joe_intel

          You may want to continue using the SATA controller in RAID mode, AHCI will do no good.

          If Windows* does not see the data, it is possible you will get better results when booting into a Linux* Live-CD so you can attempt to save the files into a different drive. You can try this option first as it is probably the safest.

          You may also get into the RAID Option ROM by pressing Ctrl+I and reset the disks to non-RAID. Theoretically, this will not destroy the data in a RAID 1 array but will remove the RAID structure just in case it became corrupted. However, this will probably not help if the issue is with the GPT.