5 Replies Latest reply on Oct 22, 2009 10:07 AM by aheadley

    Vista x64 / Intel Raid Issue

    aheadley
      Hello, First things first

       


      Configuration:

       

      • D975XBX2 Motherboard
      • ICH7-R/ICH7-DH RAID (Marvell not in use)
      • Two 1TB Drives in Raid 1
      • Vista SP2 X64
      • Intel Maxtix Storage Manager ROM 5.6.2.1002
      • Driver 6.2.0.1019 and 8.9.0.1023
      • Intel Matrix Storage Manager (Software) 8.9.0.1023
      • Bios Ver: BX97520.86A.2836.2008.0728.1946
      • Bios Ver: BX97520.86A.2838.2008.0903.1859 (current)

       

      I have had this issue for quite some time and have looked all over the Internet for help but all roads seem to point down the same path, which does not seem to work for me.

       

      Situation 1
      To start, the article at http://www.intel.com/support/chipsets/imsm/sb/CS-025783.htm notes some of the problems that I have while using driver version 6.2.0.1019:
      • Performance degradation
      • Timeout errors reported by iastor or iastor(v) in Microsoft Event Viewer*

      Though I have never had problems installing windows.

      While I am using this version of the driver I get EventID 9 in the iaStorV between every 5 and 60 mins. eventually I get a blue screen (maybe once a day) with the BugCheck D1, {38, 2, 0, fffffa6000a173ec} with WinDbg blaming iastorv.sys ( iastorv+a3ec ) for ther crash.

       

      Situation 2
      When ever I upgrade to raid driver version to 8.9.0.1023, I no longer get the EventID 9 Errors but I now get a  BSOD with BugCheck 1E, {ffffffffc0000005, fffff8000205d0e8, 0, ffffffffffffffff} and WinDbg blaming the kernel -- ntoskrnl.exe ( nt+5d0e8 ). This happens between 1 and 20 mins but sometimes as long as a few hours depending on usage of the machine, though I have had 20 BSOD's in one day in this configuration.

      I recently noticed that if I either roll back or uninstall and reinstall the driver from 8.9.x to 6.2.x I return to the original Situation 1 errors.

      In reading the "Possible issues with Windows Vista* and Intel® RAID" page it seems the work around is updating to the latest version or disabling LPM, however this fix just seems to make things worse for me and make the computer completely unstable instead of sluggish.

      I'm wondering if there is a way to solve this issue. I have also read that my ROM version must be less then 5.7.x and both BIOS versions tried had version 5.6.2.1002 and the situation did not change by updating the BIOS. i also tried cloning the drives to the Marvell controller but there is no way to disable the Intel controller while the Marvell was active so, Windows kept loading the driver and crashing anyway.

      Ive tried everything less disabling the on-board controllers and going out and purchasing another non Intel raid controller, but that seems like a silly thing to have to do.

      Any help would be greatly appreciated.

      Thanks,
      Anthony Headley