3 Replies Latest reply on Feb 9, 2015 5:35 PM by CMata_Intel

    Serial1 Stopped Working on Intel Edison

    chipmc

      To all,

       

      I have the following setup:

           - Intel Edison running the latest firmware

           - Arduino shield breakout board for Edison

           - Adafruit GPS talking at 9600 baud on Serial1 (Pins 0 and 1)

           - Bus Pirate monitoring the serial data stream

       

      I had this working the other day:

       

      /*

      Basic code to troubleshoot the Adafruit Ultimate GPS

      Connections:

        - Vin - +5

        - GND - GND

        - Rx to RX (pin 0)

        - TX to TX (pin 1)

      Not much else required.

       

       

      */

       

       

      void setup() {

        // put your setup code here, to run once:

        Serial.begin(9600);

        Serial1.begin(9600);

        Serial.println("GPS Serial1 Test Code");

        delay(1000);

      }

       

       

      char c;

       

       

      void loop() {

        // put your main code here, to run repeatedly:

        while(Serial1.available()) {

          c = Serial1.read();

          Serial.print(c);

        }

        delay(100);

      }

       

      but it no longer works - nothing changed and the bus pirate shows the correct serial flow.

       

      What to do?

       

      Chip

        • 1. Re: Serial1 Stopped Working on Intel Edison
          CMata_Intel

          Hi chipmc

           

          Could you be more specific with:

          "but it no longer works"

          Are you receiving in the Serial Monitor random values or nothing? Which is the status of the GPS shield? Are you sure that the problem it's with the code or the GPS shield could be damaged?

           

          Regards;

          CMata

          • 2. Re: Serial1 Stopped Working on Intel Edison
            chipmc

            CMata,

             

            Thanks for responding.  A little more information:

            1) I am confident that the GPS sheild is working correctly as I am monitoring the serial communications between the GPS sheild and the Edison using the Bus Pirate in High Impedance mode.  I can open a terminal and "sniff" the communications and the sheild is communicating the correct NMEA "sentences"

             

            2) I have had this sketch work correctly on a few occasions so, I think I can rule our a wiring mistake or the simplified code being wrong.

             

            3) There are two failure modes, and I am not sure how to recover from them:

                 1) The sketch transfer is complete and the serial terminal is blank other than the "Serial1 Test Code Header"

                 2) The sketch transfer does not complete and the terminal window only shows "B0100000063f69"

             

            I have tried the following to recover: pressed reset, tried the "SW1UI3 and SW1UI4" factory reset, restarted the Arduino Edison IDE and refreshed the Edison BIOS. 

             

            I am starting to think that the Intel Edison Arduino environment is not very stable.  Or I could be missing something - any help would be appreciated as I got this Edison from Instrcutables and would like to post a tutorial on GPS logging.  I have a complete sketch but need to get the basics working reliably. 

             

            Thanks,

             

            Chip

            • 3. Re: Serial1 Stopped Working on Intel Edison
              CMata_Intel

              Hi chipmc

               

              I'm sorry for the delay in my response. Have you tried to upload the code without the circuitry or shield connected? Just the board, are you getting the B0100000063f694 error ?

              Also, try using the new Release (Yocto Image) and let us know if you get improvements with this.

               

              Regards;

              CMata