9 Replies Latest reply on Feb 19, 2015 5:02 PM by CMata_Intel

    Having problems installing contextify

    AlphaCHarly

      Folks,

      I wonder if some of you is also having problems installing "contextify", I just type the command:

       

      npm install contextify


      and I get installation errors.

      I just try to install jsdom and yui in order to do some YQL queries.

      Any advice of the root of the problems will be appreciated.

      AC/.

        • 1. Re: Having problems installing contextify
          CMata_Intel

          Hi AlphaCHarly

           

          Could you attach the log after running npm install contextify? Maybe we could look in there what it's going on, I think it has to be related to a dependency so we could see which one is.

           

          Regards;

          CMata

          • 2. Re: Having problems installing contextify
            AlphaCHarly

            Here it goes :

            -----------------------

            root@Galileo2:~#  npm install contextify

            \

            > contextify@0.1.12 install /home/root/node_modules/contextify

            > node-gyp rebuild

             

            gyp ERR! build error

            gyp ERR! stack Error: not found: make

            gyp ERR! stack     at F (/usr/lib/node_modules/npm/node_modules/which/which.js:43:28)

            gyp ERR! stack     at E (/usr/lib/node_modules/npm/node_modules/which/which.js:46:29)

            gyp ERR! stack     at /usr/lib/node_modules/npm/node_modules/which/which.js:57:16

            gyp ERR! stack     at Object.oncomplete (evalmachine.<anonymous>:108:15)

            gyp ERR! System Linux 3.8.7-yocto-standard

            gyp ERR! command "node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"

            gyp ERR! cwd /home/root/node_modules/contextify

            gyp ERR! node -v v0.10.35

            gyp ERR! node-gyp -v v1.0.2

            gyp ERR! not ok

             

            npm ERR! contextify@0.1.12 install: `node-gyp rebuild`

            npm ERR! Exit status 1

            npm ERR!

            npm ERR! Failed at the contextify@0.1.12 install script.

            npm ERR! This is most likely a problem with the contextify package,

            npm ERR! not with npm itself.

            npm ERR! Tell the author that this fails on your system:

            npm ERR!     node-gyp rebuild

            npm ERR! You can get their info via:

            npm ERR!     npm owner ls contextify

            npm ERR! There is likely additional logging output above.

            npm ERR! System Linux 3.8.7-yocto-standard

            npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install" "contextify"

            npm ERR! cwd /home/root

            npm ERR! node -v v0.10.35

            npm ERR! npm -v 1.4.28

            npm ERR! code ELIFECYCLE

            npm ERR! not ok code 0

            root@Galileo2:~#

            • 3. Re: Having problems installing contextify
              CMata_Intel

              Hi AlphaCHarly

               

              Try with this:

              1. Download the package.json from npm/package.json at master · npm/npm · GitHub and put it in /home

              2. root@clanton:~# npm install

              3. root@clanton:~# npm install bindings

              4. root@clanton:~# npm install nan

              5. root@clanton:~# npm install contextify

               

              Regards;

              CMata

              1 of 1 people found this helpful
              • 4. Re: Having problems installing contextify
                CMata_Intel

                Hi  AlphaCHarly ;

                 

                Did the last suggestion work for you? Were you able to get contextify in your board?

                 

                Regards;

                CMata

                • 5. Re: Having problems installing contextify
                  AlphaCHarly

                  No luck ...same results ... I even tried with a brand new installation ...

                  AC/.

                  • 6. Re: Having problems installing contextify
                    AlphaCHarly

                    CMata,

                    A deeper look of the error message gave me the clue that it was related to the make and law the compiler tools, so I installed from the wonderful AlexT REPO:

                     

                    make

                    g++

                    gcc

                    ulibc

                    gettext

                     

                    and now it looks that is trying to compile some modules and it is missing some other library, I wonder what it is and where it is "cstring" ???

                    See the error log.

                    Thanks for your help

                    AC/.

                    --------------------

                    root@Galileo3:~# npm install nan                                                                                                                                                             

                    npm WARN package.json npm@2.5.1 No README data

                    nan@1.6.2 node_modules/nan

                    root@Galileo3:~# npm install contextify

                    npm WARN package.json npm@2.5.1 No README data

                    -

                    > contextify@0.1.13 install /home/root/node_modules/contextify

                    > node-gyp rebuild

                     

                    make: Entering directory `/home/root/node_modules/contextify/build'

                      CXX(target) Release/obj.target/contextify/src/contextify.o

                    In file included from ../src/contextify.cc:3:0:

                    ../node_modules/nan/nan.h:28:19: fatal error: cstring: No such file or directory

                    compilation terminated.

                    make: *** [Release/obj.target/contextify/src/contextify.o] Error 1

                    make: Leaving directory `/home/root/node_modules/contextify/build'

                    gyp ERR! build error

                    gyp ERR! stack Error: `make` failed with exit code: 2

                    gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:267:23)

                    gyp ERR! stack     at ChildProcess.emit (events.js:98:17)

                    gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_process.js:820:12)

                    gyp ERR! System Linux 3.8.7-yocto-standard

                    gyp ERR! command "node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"

                    gyp ERR! cwd /home/root/node_modules/contextify

                    gyp ERR! node -v v0.10.35

                    gyp ERR! node-gyp -v v1.0.1

                    gyp ERR! not ok

                     

                    npm ERR! contextify@0.1.13 install: `node-gyp rebuild`

                    npm ERR! Exit status 1

                    npm ERR!

                    npm ERR! Failed at the contextify@0.1.13 install script.

                    npm ERR! This is most likely a problem with the contextify package,

                    npm ERR! not with npm itself.

                    npm ERR! Tell the author that this fails on your system:

                    npm ERR!     node-gyp rebuild

                    npm ERR! You can get their info via:

                    npm ERR!     npm owner ls contextify

                    npm ERR! There is likely additional logging output above.

                    npm ERR! System Linux 3.8.7-yocto-standard

                    npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install" "contextify"

                    npm ERR! cwd /home/root

                    npm ERR! node -v v0.10.35

                    npm ERR! npm -v 1.4.28

                    npm ERR! code ELIFECYCLE

                    npm ERR! not ok code 0

                    root@Galileo3:~#

                    • 7. Re: Having problems installing contextify
                      AlphaCHarly

                      Keep pushing to solve the problem.

                      I installed the libstdc++ package from the AlexT repo and now the error is different, see below.

                      Thanks for the help

                      AC/.

                      --------------

                      root@Galileo3:~# npm install contextify

                      npm WARN package.json npm@2.5.1 No README data

                      -

                      > contextify@0.1.13 install /home/root/node_modules/contextify

                      > node-gyp rebuild

                       

                      make: Entering directory `/home/root/node_modules/contextify/build'

                        CXX(target) Release/obj.target/contextify/src/contextify.o

                      g++: error trying to exec 'as': execvp: No such file or directory

                      make: *** [Release/obj.target/contextify/src/contextify.o] Error 1

                      make: Leaving directory `/home/root/node_modules/contextify/build'

                      gyp ERR! build error

                      gyp ERR! stack Error: `make` failed with exit code: 2

                      gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:267:23)

                      gyp ERR! stack     at ChildProcess.emit (events.js:98:17)

                      gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_process.js:820:12)

                      gyp ERR! System Linux 3.8.7-yocto-standard

                      gyp ERR! command "node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"

                      gyp ERR! cwd /home/root/node_modules/contextify

                      gyp ERR! node -v v0.10.35

                      gyp ERR! node-gyp -v v1.0.1

                      gyp ERR! not ok

                       

                      npm ERR! contextify@0.1.13 install: `node-gyp rebuild`

                      npm ERR! Exit status 1

                      npm ERR!

                      npm ERR! Failed at the contextify@0.1.13 install script.

                      npm ERR! This is most likely a problem with the contextify package,

                      npm ERR! not with npm itself.

                      npm ERR! Tell the author that this fails on your system:

                      npm ERR!     node-gyp rebuild

                      npm ERR! You can get their info via:

                      npm ERR!     npm owner ls contextify

                      npm ERR! There is likely additional logging output above.

                      npm ERR! System Linux 3.8.7-yocto-standard

                      npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install" "contextify"

                      npm ERR! cwd /home/root

                      npm ERR! node -v v0.10.35

                      npm ERR! npm -v 1.4.28

                      npm ERR! code ELIFECYCLE

                      npm ERR! not ok code 0

                      root@Galileo3:~#

                      • 8. Re: Having problems installing contextify
                        AlphaCHarly

                        CMata_Intel,

                         

                        As a hint/clue of what is going on, I guess that is problem is related to do not have installed the full IOT SDK set and some tools/libraries are missing, so the make can not me executed.

                        I tried to add the different elements: c++, g++, make, libraries, etc, ...from the @AlexT_Intel repo,  but it looks that something is missing. I wonder what is the element missing.

                        I tried to install it on a EDISON board that I have and it installed with no problems whatsoever.

                        Watching the installation I saw that when is time to install contextify it invokes the make, the compiler, etc, ... and I guess that is where it fails on the Galileo Gen2 board.

                        Take a look of the error and give me some recommendation if you can.

                        Thanks for the help.

                        AC/.

                        • 9. Re: Having problems installing contextify
                          CMata_Intel

                          Hi AlphaCHarly ;

                           

                          Sorry for the delay in my response. Are you using the IOT image or the image from here

                          If you are using the AlexT repo you have to use the last image and if you have the IOT one you should use this repository iotdk/ . Let me know which image are you using and I will try to install it again from scratch .

                           

                          Regards;

                          CMata