3 Replies Latest reply on Jul 25, 2016 11:02 AM by Radhika.k

    "wget returned 4" during opkg update

    danny7yoo

      Hi everyone,

       

      I am trying to use Alex's repo on my 2nd Edison.

      On my first edison, it worked like a beauty but my 2nd Edison is giving me some issues.

       

      I am connected to my home WiFi and here's the error that I'm getting:

       

      root@AllansEdison:~# opkg update

      Downloading http://repo.opkg.net/edison/repo/all/Packages.gz.

      Downloading http://repo.opkg.net/edison/repo/edison/Packages.gz.

      Downloading http://repo.opkg.net/edison/repo/core2-32/Packages.gz.

      Collected errors:

      * opkg_download: Failed to download http://repo.opkg.net/edison/repo/all/Packages.gz, wget returned 4.

      * opkg_download: Failed to download http://repo.opkg.net/edison/repo/edison/Packages.gz, wget returned 4.

      * opkg_download: Failed to download http://repo.opkg.net/edison/repo/core2-32/Packages.gz, wget returned 4.

       

       

      also I tried just "wget" but no luck either

       

      wget http://repo.opkg.net/edison/repo/core2-32/Packages.gz

      --2015-01-12 05:23:07-- http://repo.opkg.net/edison/repo/core2-32/Packages.gz

      Resolving repo.opkg.net... failed: Name or service not known.

      wget: unable to resolve host address 'repo.opkg.net'

       

       

      Thanks in advance.

      Danny