1 2 Previous Next 19 Replies Latest reply on Apr 28, 2011 8:43 AM by

    Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2

    moseygilbert

      I have a fresh installation of Windows Server 2008 R2 and a dual port PRO/1000 PT Intel network interface card that I am trying to team. I have installed the latest drivers from intel.com, which includes the PROSet for Windows Device Manager. Under properties for the NICs, I notice the Intel tab, Advanced - however, I cannot seem to get the Teaming tab to show up. What am I missing?

        • 1. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
          mark_h_@intel

          The Intel® PRO/1000 PT Dual Port Server Adapter has full support for Windows* Server 2008 R2. Are you trying to create the team from a different adapter? Some of the older adapters do not have full support for Windows Server 2008 R2, and no teaming tab would show up in those adapters' properties.

           

          Did you install ANS along with Intel® PROSet? You need ANS to get the tab for configuring teaming. Which download did you get from intel.com? Make sure you have the 64-bit web pack for Windows* 7 and Windows Server 2008 R2 and not the web pack for Vista. The file you need is PROWIN7X64.exe.

           

          Let me know if any of suggestions worked for you.

          • 2. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
            moseygilbert

            Mark,

             

            Thanks for the response...

             

            I have the PCI Express (EXPI9402) Intel® PRO/1000 PT Dual Port Server Adapter, which supposedly has full support according to the link you provided. I installed the PROWIN7X64.exe file previous, the same one that you mentioned, and made sure to include the Advanced ... (ANS). I thought that maybe a screenshot of the properties of the NIC would be beneficial, see attached.

             

            Untitled.jpg

            Untitled2.jpg

            Untitled3.jpg

            • 3. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
              mark_h_@intel

              Looks like Intel(R) PROSet cannot see ANS. I have to suspect some other application that might insert virtual NICs into the network stack and is blocking ANS from functioning. These adapters are usually hidden by Windows* Device Manager. Use View...Show hidden devices to check for this type of adapter. Some of the suites with firewall/intrusion protection/anti-virus software add such adapters.

               

              If you discover one of these adapters, you could find out if that is causing the issue by uninstalling the software that adds the adapters. Then reinstall the Intel software. If you get the teaming tabs, then you will at least have identified a cause.

               

              You might even be able to work around the problem by setting up the teams first, then installing the other software. I have seen changing the order like this allow teams to be created and work when similar issues occurred.

               

              Let me know what you find out.

              • 4. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
                Jem_Bayliss

                Hi. I have the same problem as above with my Pro/1000 PT Dual Nic.

                 

                The installation is a clean install of windows server 2008 standard R2 x64 with no other software installed. If I disable one of the dual ports the teaming tab is there but I cannot do anything with it otherwise the tab is missing. I cannot see any of the hidden devices you mentioned. And I was wondering if anything more had been found out about this?

                 

                Many Thanks

                • 5. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
                  mark_h_@intel

                  Last night I made a clean install of Windows* 2008 R2. Then I ran the PROWIN7X64.exeinstaller from Intel Download Center. I have multiple adapters installed, and one of them is the Intel(R) PRO/1000 PT Dual Port Server Adapter. I can configure teams on the Teaming tab without any problem.

                   

                  Intel(R) PROSet uses the Windows Management Instrumentation (WMI) service to provide the tabs. By experimentation, I know that launching Intel PROSet will launch the WMI service if the service is stopped. However, if security settings stop the service from launching, then the tabs controlled by Intel PROSet will not be available. I would check the WMI service to make sure it is running and set as automatic.

                   

                  Another thing I would try is uninstalling the drivers, Intel PROSet, and ANS. Then I would do a new install of the adapter software using  PROWIN7X64.exe.

                   

                  If none of the above helps, I would look for software that might have been installed as part of another device's installation that might do something that interferes with the adapter software. I am not aware of any instances where other devices are causing a problem with teaming tabs in Windows* Server 2008 R2. I am just trying to think of possible causes to help you find the cause and resolve it.

                   

                  Out of curiosity, do you have any other NICs in your server besides the Intel PRO/1000 PT Dual Port Server Adapter? I do not know if that matters, I am just trying to understand what might be different to cause an issue on your server, but not on every other server.

                   

                  Keep us posted on whatever you find.

                  • 6. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
                    moseygilbert

                    Jem_Bayliss,

                     

                    Your post helped a bit...when I disabled one of the ports on the dual card, the remaining enabled NIC had the Teaming tab. Interesting for me, however, was when I re-enabled that port, the Teaming tab remained. However, that was not the complete resolution. Following that, I could not team because the card came with iSCSI boot enabled, which apparently disables Teaming. In the device properties, Teaming tab, it stated "This adapter is configured for an intel iSCSI Remote Boot image. You cannot use this adapter in a team."

                     

                    The final resolution was to flash the cards, removing the iSCSI functionality. From the Intel PROBOOT.EXE tools package for this card, I had to boot into DOS (I have a DOS 6.22 bootable CD) and run the following:

                     

                    1. ibautil -all -flashenable

                     

                    -reboot your computer into DOS again-

                    2. ibautil -all -upgrade

                    -reboot into Windows-

                     

                    Now I can team the ports on the card...

                     

                    As a side note, when you create the team, MAKE SURE its actually completed the process before you modify the properties for that team. You can check when its fully active by running ipconfig and watching for that LAN interface to appear. I modified it before it was completed (takes 3 minutes or so with LACP team) and set an IP address, it messed up the registry for that interface and made the team completely useless.

                     

                    -Aaron

                    www.devtrends.com

                     

                    Message was edited by: moseygilbert

                    • 7. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
                      mark_h_@intel

                      Thanks for sharing the fix.I knew that you could not team an adapter that is configured to do Intel(R) iSCSI boot, but I never heard of the teaming tab being hidden.Knowing this can happen will probably save a headache for lots of other people.

                       

                      By the way, if someone else encounters the same issue, you might not have to change the flash image. You should be able to disable Intel iSCSI boot on an adapter during the boot message from the adapter. If you press control+d, you get a menu allowing you to disable the adapter for the iSCSI boot function. (Or you can change primary and secondary choices from the same menu.)

                      • 8. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
                        moraga695

                        I have the same issue. Newly upgraded to Server 2008 R2 from Server 2003 with PRO/1000 PT Dual Port Server Adapter and the teaming tab is NOT available. I noticed that if a port is disabled, the teaming tab shows up but, of course, you can't do anything with it. When you reenable the port the tab goes away again. This same adapter would team fine when the OS was Server 2003. Does that mean that I don't need to worry about the iSCSI settings mentioned in some of the replies? I hope Intel figures out what the problem is soon. Meantime, I guess I'll run with one of the ports disabled.

                         

                        Thanks much for your advice.

                        • 9. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
                          mark_h_@intel

                          The most likely cause is that Intel(R) ISCSI Boot is enabled on the ports of your adapter. You will have to disable Intel ISCSI Boot using the control+d during boot up. Or you could use the ISCSI Boot utility to disable ISCSI boot or flash the adapter with Intel Boot Agent. Disabling with control+d will likely be easier.

                           

                          I would look at this as the cause first. I checked this out with Windows* 7 earlier today and with ISCSI Boot enabled, teaming was available. The same adapter port in Windows Server 2008 R2 did not show the teaming tab (or the VLAN tab.) Disabling ISCSI boot brought back the missing tabs.

                           

                          Let us know if this does not resolve it for you.

                          • 10. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
                            moraga695

                            Hello Mark H,

                             

                            Thanks for your reply of August 21 about my inability to team my Pro/1000 dual port server adapter in Server 2008 R2. You and others mention that if iSCSI boot is enabled, teaming is not available and you suggested I first disable iSCSI booting. Maybe I'm ignorant about the subject, but my adapter is still in the state it was in when shipped from Intel - NOTHING is flashed into its ROM. As I understand it, server adapters are usually shipped that way. So unless I misunderstand something, iSCSI booting is not causing my problem. Please advise.

                             

                            Thanks very much.

                            • 11. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
                              mark_h_@intel

                              Even though you did not enable ISCSI boot, you should still try the disable ISCSI boot solution. Your description is exactly the same as seen by other users who used the same solution. I do not know why ISCSI boot appears to be enabled, but this is still the most likely cause. Let us know if disabling ISCSI boot on the adapter does not work.

                              • 12. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
                                Jem_Bayliss

                                Hi Mark

                                 

                                I've tried to find the Control+D option but can't and I have booted into DOS with the ibautil.exe and cannot find and option to disable ISCSI. I've never enabled these options either and the cards teamed perfectly well together on windows server 2003 R2. I am also having the problem with the PRO/1000 MT Dual card. But i'm guessing the problem will be the same as my PT dual card??

                                 

                                Can you explain in simple terms how to disable ISCSI boot solution and I will have another go.

                                 

                                Thanks

                                • 13. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
                                  wrightju

                                  Hello,

                                   

                                  To disable iSCSI remote boot, you can use iSCSIUtil (http://downloadmirror.intel.com/12194/eng/ISBoot.exe&agr=y&DwnldId=12194).

                                   

                                  Extract the files to your hard drive then copy "iscsiutl.exe" & "iscsiutl.txt" files under ..\intel14.3\iscsiutl\dos\ to a DOS bootable floppy or pen drive.

                                  Then from DOS, run the command:

                                   

                                  iSCSIUtl -all -flashdisable

                                   

                                  This will disable iscsi boot flash for all Intel NICs.

                                   

                                  -Justin

                                  • 14. Re: Missing PRO/1000 PT Dual NIC Teaming with Server 2008 R2
                                    mark_h_@intel

                                    As to "I am also having the problem with the PRO/1000 MT Dual card," the cause is different. Unfortunately, the Intel® PRO/1000 MT Dual Port Server Adapter does not have Intel® PROSet and ANS support in Windows Server 2008 R2. You can add Intel PRO/1000 MT Dual Port Server Adapter ports to a team if you create the team using one of the newer adapters such as your Intel PRO/1000 PT Dual Port Server Adapter.

                                     

                                    In case you are wondering about other Intel Ethernet adapters you have, check out Is my Intel® Ethernet Adapter supported in Microsoft Windows Server* 2008 R2?

                                    1 2 Previous Next