8 Replies Latest reply on Feb 26, 2015 9:26 AM by mhahn

    adding FTDI_USB to Edison kernel

    mhahn

      tried

      bitbake -c menuconfig linux-yocto
      bitbake -f -c deploy linux-yocto
      

       

      the configuration in device-drivers->USB->USB serial -> FTDI has been taken fine. But in contrast to other modules I have successfully compiled and deployed in the past bitbake seems to ignore this module as the module isn't put into the tarball nor built at all.

       

      Could possibly one of the dozen patches void my .config setting?

       

      Any clue?

        • 1. Re: adding FTDI_USB to Edison kernel
          mhahn

          modifying the recipe defconfig directly worked - but I don't get why the .config isn't taken - maybe partly overwritten by the defconfig?

          • 2. Re: adding FTDI_USB to Edison kernel
            CMata_Intel

            Hi mhahn

             

            Could you add the .config setting file of the driver and the local.conf? and maybe a screenshot with the changes that you have made and one after bitbake -c menuconfig linux-yocto we could try to see what happened checking that.

             

            Regards;

            CMata

            • 3. Re: adding FTDI_USB to Edison kernel
              mhahn

              the only change in .config via "bitbake -c menuconfig linux-yocto":

               

                │ Symbol: USB_SERIAL_FTDI_SIO [=m]                                        │  
                │ Type  : tristate                                                        │  
                │ Prompt: USB FTDI Single Port Serial Driver                              │  
                │   Location:                                                             │  
                │     -> Device Drivers                                                   │  
                │       -> USB support (USB_SUPPORT [=y])                                 │  
                │ (1)     -> USB Serial Converter support (USB_SERIAL [=y])               │  
                │   Defined at drivers/usb/serial/Kconfig:148                             │  
                │   Depends on: USB_SUPPORT [=y] && USB [=y] && USB_SERIAL [=y]    
              

               

              i.e. setting CONFIG_USB_SERIAL_FTDI_SIO=m

              • 4. Re: adding FTDI_USB to Edison kernel
                CMata_Intel

                Hi mhahn

                 

                For USB modules you need to modify the defconfig in order to make it work when you compile. You need to do these changes when the module is related to hardware.

                 

                Regards;

                CMata

                • 5. Re: adding FTDI_USB to Edison kernel
                  mhahn

                  sorry, don't quite get this. It's clear that patching the defconfig in the recipe will work. It's still not clear why the .config generated via "bitbake -c menuconfig linux-yocto" isn't picked up when running "bitbake -c compile_kernelmodules" doesn't seem to pick up that .config. Maybe I did something wrong?

                  • 6. Re: adding FTDI_USB to Edison kernel
                    CMata_Intel

                    Could you test it with bitbake virtual/kernel -c menuconfig instead of bitbake -c menuconfig linux-yocto?

                     

                    -CMata

                    • 7. Re: adding FTDI_USB to Edison kernel
                      mhahn

                      thanks for the proposal. I don't have time right now and have my workaround. If I have to recompile the kernel / modules again I will try to test

                      • 8. Re: adding FTDI_USB to Edison kernel
                        mhahn

                        just tried it - "virtual/kernel" seems to be just a placeholder for the concrete kernel (in our case "linux-yocto". Hence won't make a difference