1 2 Previous Next 17 Replies Latest reply on Sep 28, 2016 11:04 AM by floydg

    MRAA stopped working

    Frederick Blais

      In the past few weeks I used lib mraa a lot with Python. To get simple visual feed back, I like to turn ON/OFF the on-board LED on pin 13.

       

      For some reason, that stopped working, I'm not able to get the pin high anymore. I suspect that my entire mraa is not working because I'm not able to get ADC working anymore too :

      ValueError: Invalid AIO pin specified - do you have an ADC?

      In the Python interpreter, when I try to put the pin in Output mode, I have this :

      >>> x.dir(mraa.DIR_OUT)

      0

      >>> x.write(1)

      0

       

      As far as I know, I received a 1 in the past. Can someone confirm this?

       

      I tried to get mraa to work with C but no luck either.

      I tried to re-install mraa. The installation went fine. It is not working either.

       

      someone have an advice on what I should do to get that going on again?

        1 2 Previous Next