3 Replies Latest reply on Jan 21, 2015 4:23 PM by Jesthenis

    Boot Partition Error

    Jesthenis

      I was trying to change partition size of my Edison. And then I reboot it. Now , it loops on boot squence whenever I plug in edison. I ` ve tried run do_ota but it is still looping. I can reach u-boot but I cannot reach Edison disk from usb . I also tried flashall.sh flashall.sh --recovery commands. But it goes timed out . Any idea to fix that from u-boot commands ? Here is my boot sequence

       

      Thanks.

       

      EDIT:

      here is my partition

       

      boot > printenv partitions

      partitions=uuid_disk=${uuid_disk};name=u-boot0,start=1MiB,size=2MiB,uuid=${uuid_uboot0};name=u-boot-env0,size=1MiB,uuid=${uuid_uboot_env0};name=u-boot1,size=2MiB,uuid=${uuid_uboot1};name=u-boot-env1,size=1MiB,uuid=${uuid_uboot_env1};name=factory,size=1MiB,uuid=${uuid_factory};name=panic,size=24MiB,uuid=${uuid_panic};name=boot,size=32MiB,uuid=${uuid_boot};name=rootfs,size=512MiB,uuid=${uuid_rootfs};name=update,size=768MiB,uuid=${uuid_update};name=home,size=-,uuid=${uuid_home};

      boot > mmc part

       

       

      Partition Map for MMC device 0  --   Partition Type: DOS

       

       

      Part    Start Sector    Num Sectors     UUID            Type

        2     16              7634928         00000000-02     83

       

      ******************************

      PSH KERNEL VERSION: b0182727

                      WR: 20104000

      ******************************

       

       

      SCU IPC: 0x800000d0  0xfffce92c

       

       

      PSH miaHOB version: TNG.B0.VVBD.0000000c

       

       

      microkernel built 23:15:13 Apr 24 2014

       

       

      ******* PSH loader *******

      PCM page cache size = 192 KB

      Cache Constraint = 0 Pages

      Arming IPC driver ..

      Adding page store pool ..

      PagestoreAddr(IMR Start Address) = 0x04899000

      pageStoreSize(IMR Size)          = 0x00080000

       

       

      *** Ready to receive application ***

       

       

       

       

      U-Boot 2014.04 (Oct 14 2014 - 15:19:04)

       

       

             Watchdog enabled

      DRAM:  980.6 MiB

      MMC:   tangier_sdhci: 0

      In:    serial

      Out:   serial

      Err:   serial

      Hit any key to stop autoboot:  0

      Target:blank

      Partitioning already done...

      Flashing already done...

      dfu_fill_entity_mmc: could not find partition #1 on mmc device #0!

      ERROR: DFU entities configuration failed!

       

       

      at drivers/dfu/dfu.c:71/dfu_init_env_entities()

      dfu - Device Firmware Upgrade

       

       

      Usage:

      dfu <USB_controller> <interface> <dev> [list|timeout]

        - device firmware upgrade via <USB_controller>

          on device <dev>, attached to interface

          <interface>

          [list] - list available alt settings

          [timeout] - specify inactivity timeout in sec, doesn't work whit list

      ** Invalid partition 7 **

      Error: Invalid Boot Flag (found 0xffef, expected 0xaa55)

      ## Kernel loading failed ...

      zboot - Boot bzImage

       

       

      Usage:

      zboot [addr] [size] [initrd addr] [initrd size]

            addr -        The optional starting address of the bzimage.

                          If not set it defaults to the environment

                          variable "fileaddr".

            size -        The optional size of the bzimage. Defaults to

                          zero.

            initrd addr - The address of the initrd image to use, if any.

            initrd size - The size of the initrd image to use, if any.

       

       

      Unknown boot mode: boot

      Saving Environment to MMC...

      Writing to MMC(0)... done

      Resetting to default boot mode and reboot...

      resetting ...