5 Replies Latest reply on Feb 8, 2015 2:05 PM by xbolshe

    Galileo Gen2 not responding

    Sylexx

      Hi all,

       

      i am working on a project including the Galileo Gen2 Board. Unfortunately my Board isn't responding anymore. I already tried the following steps:

       

      • Grounding the golden square next to FWR label to force recovery and recover the contents of the SPI flash --> No Serial Output
      • Flashing a generated Firmware using DediProg:
        • Download Flash Missing PDAT Release  from https://communities.intel.com/docs/DOC-22226
        • Create platform-data.ini ( Attached to this post)
        • run ./platform-data-patch.py -p platform-data.ini -i ~/galileo/Flash-missingPDAT_Release-1.0.4.bin
        • flash using dediprog
        • --> Still not responding and no serial debug ouput

       

      The board is not recognized by my computer, there is no debug information on the serial port and after powering "L"-LED is on for a short time. After that only the "ON"-LED is on.

       

      I would be thankful for every help.

        • 1. Re: Galileo Gen2
          Intel_Alvarado

          Hi Sylexx,

           

          Have you tried following this guide http://www.intel.com/support/galileo/sb/CS-035030.htm ? The procedure listed here seems similar to the first step you followed since you mention a force recovery. If this is the case I believe you are grounding the wrong element. Take a look at step 8 and open the document guide. In figure 5 of section 2.5.4 the element that needs to be grounded is a resistor. Try following this guide and report your results.

           

          Regards

          Sergio

          • 2. Re: Galileo Gen2
            Sylexx

            Hi Sergio,

            thanks for your reply.

            Indeed, we are following the guide you linked. The version on the webpage does not explicitly mention it, but the "short the resistor" part does NOT apply to Galileo Gen2 boards (which we are working with). It is a part of the Galileo Board User Guide (available as PDF ) which clearly targets Galileo Gen1.

            Apart from that, we have a working board that boots and use it to test and verify our serial connection as well as our assumption that instead of the resistor, the FWR golden square needs to be connected with GND to force recovery mode. My coworker recovered a third board using this method, so I am sure it works and the guide that you linked to is outdated. I could not find an updated guide however...

            As already stated, we are trying to get this board to work again using a DediProg SF100, flashing it as described in Section 11 of the BSP Build and Software User Guide. Regardless, we do not get any response except the LEDs.

             

            Regards,

            Sylexx

            • 3. Re: Galileo Gen2 not responding
              DiegoV_Intel

              Hi Sylexx,

               

              Take a look at this thread: Intel Galileo Gen 2 board bricked. There is a troubleshooting about recovering a Galileo Gen2 board. The process that appears at the end of the thread might be useful for you.

               

              Regards,

              Diego.

              • 4. Re: Galileo Gen2 not responding
                xbolshe

                Hi,

                 

                I may confirm that the same situation (no board response) is present in case of Gen1, when I use "Flash-missingPDAT_Release-1.0.4.bin" patched with using "platform-data-patch.py".

                But if I use a backuped flash image, there is no problem.

                 

                It seems that there is a problem in 'Flash-missingPDAT_Release-1.0.4.bin' or patching method.

                 

                xbolshe

                • 5. Re: Galileo Gen2 not responding
                  xbolshe

                  Ohh... I have found my error. It was related with 'platform-data.ini' and MRC parameters block ID.

                  I have fixed my error and found no problem with Gen1: it works with using "Flash-missingPDAT_Release-1.0.4.bin" and "platform-data-patch.py"

                   

                   

                  Let us see a part of 'platform-data.ini' provided by :

                   

                  Part of platform-data.ini

                  # WARNING: the platform type data.value MUST match the MRC data.value below

                  [Platform Type]

                  id=1

                  desc=PlatformID

                  data.type=hex.uint16

                  # ClantonPeak 2, KipsBay 3, CrossHill 4, ClantonHill 5, KipsBay-fabD 6, GalileoGen2 8

                  data.value=8

                   

                   

                  # WARNING: the MRC data.value MUST match the platform type data.value above

                  [Mrc Params]

                  id=6

                  ver=1

                  desc=MrcParams

                  data.type=file

                  #data.value=MRC/clantonpeak.v1.bin

                  #data.value=MRC/kipsbay.v1.bin

                  #data.value=MRC/crosshill.v1.bin

                  #data.value=MRC/clantonhill.v1.bin

                  #data.value=MRC/kipsbay-fabD.v1.bin

                  data.value=MRC/GalileoGen2.bin

                   

                  In my understanding it is required to change it like shown below:

                   

                  [Mrc Params]

                  id=8

                  ver=1