4 Replies Latest reply on Jan 25, 2015 1:08 PM by KennethB

    D54250WYKH no screen on bios

    KennethB

      Let me start off by saying im really happy with this little device, however there seems to be a little annoyance with the BIOS.

       

      My NUC is running ubuntu, hooked up to my sony hdtv with a minihdmi to hdmi cable and running with a wireless usb keyboard.

      When trying to enter the bios (v0033) i just got a black screen. Not a dead black screen, the tv received a signal just didnt display anything. After googling around i ended up here and i saw many ppl with similar problems so started following the steps.

       

      Hooked the nuc up to a regular pc display with minihdmi to dvi. Nothing

      Hooked the nuc up to a regulat pc display with minidp to vga. Nothing

      Replaced the wireless keyboard by a regular wired keyboard. Nothing

      Moved the bios jumper on the the board. Nothing

      Removed the bios jumper on the board. Nothing

       

      So then i got slightly annoyed and downloaded the oldest bios version on your website, put it on a usb stick and ran bios recovery. It installed bios v0018, booted up and got into the bios had a  nice screen and everything. So then i figured i might aswell download a few more versions and upgrade till i come across the latest one that works. But turned out i couldnt upgrade the bios using the regular way (F7) so i always had to put the version i wanted on a usb stick and upgrade it using the recovery mode. To keep a very long story long (cause lets face it it aint gonna get short anymore at this point), i tried using, 0018 0025 0028 0030 and 0033 the latest working BIOS version for me was BIOS Version 0025 - WYLPT10H.86A.0025.2014.0303.1008

       

      Now i dont really like running an older bios version then i had before but on the other hand id like to be able to enter my bios when i need to... Reason why i wanted to enter it was to use the Wake On Lan option but since when i entered the v0025 one it seemed it was on the correct setting standard so im hoping it will be the same with the v0033. Im just putting this down here hoping you guys will come up with a fix for this at some point.

        • 1. Re: D54250WYKH no screen on bios
          kevin_intel

          Hello KennethB,

           

          I think this could be related to the Operating System installed. I have been testing this NUC with TV connected as main monitor or normal PC monitors and I have no issues.

           

          I know you are a linux user but, have you tried replicating this on Windows version?

           

          Kevin M

          • 2. Re: D54250WYKH no screen on bios
            KennethB

            Could be me but i dont really see how the OS installed could effect if you have a display when entering on BIOS or not cause when loading the BIOS the OS isnt loaded yet is it? Havent tried with windows installed no but i have tried without a disk installed. Either way as i said its not a big deal just an inconvenience if you ever have to change anything in the BIOS. Maybe next time ill swap out the disk and put a quick windows install on it when i want to try it, however for now the Wake On Lan is working after i upgraded back to BIOS 0033 so i guess its enabled by default.

            • 3. Re: D54250WYKH no screen on bios
              Apachez

              Yeah I guess kevin was misreading your post or something.

               

              Intel changed the behaviour of output detection at around bios version 0026 or so (I dont recall the exact version this happend).

               

              This means that they will output a 1024 screen using the detected native format. That is if the native format is lets say 2560 pixels then you will have a 1024 pixel wide picture in the middle of your 2560 pixel picture with black bars surrounding your 1024 pixel bios screen.

               

              Compared to previously where the bios would output a 1024 pixel signal instead.

               

              I think this can be the cause that BIOS doesnt work on many tv's now (and/or when being used through a receiver or other hdmi components).

               

              So if possible, try get 0025 (or so) and see if you get a bios screen there and then take notes on which version the bios screen stops working with your tv and file that as a bug report towards Intel.

              • 4. Re: D54250WYKH no screen on bios
                KennethB

                Hey,

                thanks for the response, that does indeed seem to be whats happening to me however i cant get the bios to give me a display on any screen available to me. Tried with a Sony 40"HDTV, 22" iiyama Prolite T2250MTS and an old iisonic 17" display. Tried both over the minihdmi and displayport connection.

                 

                Altho my problem is fixed and im still running 0033 so as long as i dont have to change anything else in the bios its ok

                Ill look into a bug report so it might get fixed towards the future.