3 Replies Latest reply on Jan 21, 2015 11:25 AM by CMata_Intel

    Edison Python not working

    BuffordHumbkingle

      Hello Everybody,

       

      After flashing my Edison board, I tried to test out some MRAA examples in the "/usr/share/mraa/examples/python" folder. After testing out the blink example, just to make sure everything was running properly, I went ahead and ran the aio.py file to read my LM35 temp. sensor in Analog pin 0. Running the program, I got the expected result. After running the same program again though, I only got a value of 0. So the first time I ran aio.py, I got a reasonable analog value but after running it twice (and more), the "mraa.Aio(0)" method returned a value of 0. But the really strange part was that when I went into the python console, and ran the exact same lines of code, the "mraa.Aio(0)" method returned reasonable analog values (ie: 176, 198, 148). I also ran a loop which printed out the analog values without a delay in time just to see if it was a timing problem, and it still ran fine! If any of you can help me, that would be fantastic.

       

      -Bufford Humbkingle