4 Replies Latest reply on Jan 19, 2015 9:14 PM by tintar

    Pre-built Edison image with larger /dev/root partition?

    gtmtg

      Hi! I'm trying to install libraries that I need for my project (OpenCV, FFmpeg, etc.) on the Edison and I'm out of space. I wanted to increase the size of the /dev/root partition (as detailed in this thread) but I simply don't have the 50+ GB necessary to set up a build system. If someone would be able to upload their image with an increased partition size to Dropbox, etc. and post the link here, I (and others) would be very grateful. Thanks in advance!

        • 1. Re: Pre-built Edison image with larger /dev/root partition?
          Andre.M

          have you tried to increase the size with parted?

          not sure if its possible with the mounted root partition

          • 2. Re: Pre-built Edison image with larger /dev/root partition?
            intel_jassowski

            I've tried that with no success.  I started by trying to decrease the size of the home partition with parted.  I found that if you umount /home, it automatically remounts (maybe there's an mtab option or service that controls this, not sure).  That was keeping me from even starting parted on that partition.  However I did come up with a kludge:

            umount /home ; fsck /dev/mmcblk0p10

            then immediately hit ctrl-Z before fsck finishes.  Now /home appears to remain unmounted and I can run parted.  However, deleting and recreating the /home partition with a smaller size didn't really seem to work and caused the Edison to fail to boot.

             

            I agree that it certainly would be nice to have a way to resize partitions in a live Yocto image.

            • 3. Re: Pre-built Edison image with larger /dev/root partition?
              Andre.M

              cant replicate the issues you had

              could you be more specific why your edison failed to boot, error message or whatever?

              • 4. Re: Pre-built Edison image with larger /dev/root partition?
                tintar

                although it scares me (for no sound reason, only that it "feels" inelegant - lol), you're quite right: technically, using parted/resize2fs or other equivalents, should not only work with online FS, but be safe.

                 

                hrm, I can

                cd /

                sudo umount /home

                 

                with no problem. although this is with ubilinux. and neither fstab nor mtab have anything weird-looking. quite possibly yocto has other ideas...?

                 

                I'm not doing any e.g production of a huge amount of Edisons, so my lazy carcass has been happy enough to simply move+symlink large stuff into /home and/or USB.

                 

                not sure about the sparkfun SD boards, but I am really happy now having finally gotten the arduino-variant - the transflash slot janks directly into the SD controller and not thru clunky USB, so this is an inexpensive, effective way to add fast+useful diskspace. (Intel's own mini board can technically do this as well, as long as you're in the mood for soldering...)