9 Replies Latest reply on Jan 25, 2015 9:36 AM by Brepster

    Can CIR permanently be disabled?

    Brepster

      Hello everybody,

       

      I own an intel NUC D34010WYK and it is working fine under Windows so far. However, I have a small problem which is really annoying: apparently, my TV receiver and the NUC both use the same IR frequencies. As a consequence, when I turn on my TV receiver by using its remote, it also turns on the NUC. I am talking here about a start of the NUC 'from cold', not from standby. I found already a corresponding entry in the BIOS (latest) for turning off the CIR but, unfortunately, it does not work. Even, if I switch it off in the BIOS, the NUC still starts from cold when I turn on my TV receiver.

       

      I have also changed the IR frequencies of my TV receiver and its remote to several other values (4 different options are possible), however, the NUC seems to respond to any of these frequencies and the problem remains.

       

      I know that most people here have more probably the problem of a non-working CIR but in my case it is the opposite case: I simply don't need it and would like to get rid of it.

       

      Does anybody here have a suggestion for a solution of this weird problem? By the way: the Intel support told me that actually it should not be possible to turn on the NUC from cold by using an IR remote but only from standby. This makes the whole issue even more strange for me...

       

      Thank you for any help in advance!

       

      Best regards,

      Brepster

        • 1. Re: Can CIR permanently be disabled?
          joe_intel

          Based on my tests, the CIR can power the Intel® NUC from sleep and from shutdown but not when the feature is disabled in BIOS.

          Did you try disabling the Nuvoton SIO CIR device driver in Device Manager? This driver should not appear if the CIR is disabled in BIOS.

          You may also disable Microsoft eHome Infrared Transceiver just in case.

          • 2. Re: Can CIR permanently be disabled?
            Brepster

            Dear joe_intel,

             

            first of all, thank you for your kind answer!

             

            Mmmh..this is strange. I tested several times to disable the CIR device in the BIOS. As I said, in my case, it did not seem to have any influence since the NUC still started from cold i.e. from a shutdown state. However, I will once again try it when I return home from work this evening and give you a feedback.

             

            Regarding your suggestion to disable the CIR in the Windows device manager: I have tried that also with no success, unfortunately. It still led to the same behavior. Interestingly enough, another person from the Intel support had the same suggestion as you but it is anyway not clear to me how disabling the driver in the device manager should have any influence on the "start from cold" issue. At that point of time, no OS is loaded at all...

             

            Thank you once again!

             

            Best regards,

             

            Brepster

            • 3. Re: Can CIR permanently be disabled?
              jan_andersen

              You could cover the IR sensor on your NUC with a piece of black tape.

              • 4. Re: Can CIR permanently be disabled?
                dougho

                Joe, I suggest you re-test - I disable CIR in my D52450 current BIOS, and it keeps powering up when I press the IR Pause button or the IR Power button.

                Someone else said there is some setting about disable wake from USB or something like that which might be the workaround (I haven't tried that - mine is default).

                Note that I did not unplug the AC power cord after disabling IR in BIOS (I seem to recall behavior sometimes varies if you unplug the power cord, for example I think that step may have been necessary after some Bluetooth or WiFi driver update).

                • 5. Re: Can CIR permanently be disabled?
                  joe_intel

                  OK, now I see it happening in our system.

                  Do you guys know if this was happening with a previous BIOS version?

                  • 6. Re: Can CIR permanently be disabled?
                    Brepster

                    Dear all and especially Joe,

                     

                    I am sorry for my late reply but I was quite busy during the last days and I did not find the time to write back. Fortunately, the problem is solved for me now! The solution is somewhat strange and was implicitly given in the answer by dougho: I switched again CIR off in the BIOS. However, this time I really unplugged the AC power over night (the reason for this was actually due to another problem described later). When I plugged-in the AC power again the next morning, the problem was gone! The NUC now does not power up when I turn on my TV via the remote.

                     

                    This is really strange. Does it maybe have something to do with the unloading of the electrical capacitors inside the NUC? I am really not an expert in this...but I do not care so much about it as long as the NUC is working as expected.

                     

                    I am quite happy with my NUC now, there is only one strange behavior left which I do not understand. Maybe you can help with that.

                     

                    Some additional information first: I have 'Wake on LAN' enabled in the BIOS because I really need it and I have activated 'Deep S4/S5'. My NUC is connected to my router via ethernet cable.

                     

                    Now the problem: Everytime I put Windows 7 into a state of energy saving (either standby or hibernation), the NUC only 'sleeps' for some seconds, then the NUC wakes up again immediately! Even if I then truly shutdown the system, the NUC starts again from cold. The only thing which helps is to unplug the NUC for some seconds from the AC power and then start Windows 7 again. In this case, the system works as expected and it really stays off when I shut down the NUC. Accordingly, the described behavior only occurs when the NUC was put into a state of energy once. Do you know why this problem emerges? I initially thought that maybe my router is constantly sending 'Magic packets' to the NUC...but this would not explain why the NUC then stays off after shortly unplugging it from the AC power.

                     

                    I am sorry for the long explanation! Thanks to everybody contributing to this discussion!

                     

                    Best regards,

                    Brepster

                     

                    P.S.: Would it be better to start a new thread for this topic?

                    • 7. Re: Can CIR permanently be disabled?
                      joe_intel

                      Thanks for posting the solution. That is probably why I failed to replicate the issue in the beginning.

                      Regarding the wake up issue, what other power options are enabled? Is Intel® Rapid Start Technology enabled?

                      Try disabling it or resetting all of them back to default. Otherwise, you can create a new thread for this topic.

                      • 8. Re: Can CIR permanently be disabled?
                        LeszekM

                        Since Wake-on-lan AND waking from S4/S5 are both enabled, I would look into something turning your nuc on via lan.

                        • 9. Re: Can CIR permanently be disabled?
                          Brepster

                          Okay guys, it seems I have solved also my second problem concerning the 'waking up from standby' issue. It was actually related to a specific Windows 7 setting. I had to go into the adapter settings for my ethernet adapter, then under power management. There, in addition to 'Allow this device to wake the computer' (which was already activated), I had to check the 'Only allow a magic packet to wake the computer'. Now, everything is working as expected! Beautiful! :-)

                           

                          Best regards,

                          Brepster