5 Replies Latest reply on Jan 20, 2015 12:32 PM by kevin_intel

    Raid defect? raid bios (RST) not accessible using ctrl-i

    kabolz

      Hello,

       

      I have a problem with my intel raid controller. I formatted ssd and hdd in my ultrabook and deleted alle raid clusters in the raid bios while startup (ctrl - i). Since then, I have no chance at all to get into the raid bios again. I switched sata controller mode to ahci or raid, both the same result: no possibility to use ctrl-i to get into the raid configuration tool. Now I'm afraid that my raid controller is defect and does not support raid anymore. in AHCI mode SSD and HDD work fine, installation of Win7 on both has been successfull.

       

      Chipset:     hm77, rev. 04 (C216)

      Bridge:     Ivy bridge

      CPU:     i5-3317u Family 6, Modell A, Stepping 9, ExtModell 3A, Revision E1/L1

      SSD:     Samsung MZMPC032HBCD-000L1

      HDD:     Samsung ST500LT012-9WS142

       

      Could you please help me?

      thanks in advance

      Uwe

        • 1. Re: Raid defect? raid bios (RST) not accessible using ctrl-i
          kevin_intel

          Hello kabolz,

           

          Let me help you with this.

           

          When trying to setup a RAID with Intel® Rapid Storage Technology it is necessary to have the chipset mode set as RAID. This is the only way to have the CTRL-I BIOS enabled.

           

          I see you have installed Windows 7 on AHCI mode already so you will need to set the Chipset mode to RAID and reinstall the Operating System.

          You can create the RAID volume by pressing CTRL + I keys when booting or you also can use Intel® Rapid Storage Technology to create the RAID volume from the software.

           

          Here you have the Intel® Rapid Storage Technology user guide:

          http://www.intel.com/support/chipsets/imsm/sb/CS-020670.htm

           

          Kevin M

          • 2. Re: Raid defect? raid bios (RST) not accessible using ctrl-i
            kabolz

            Hi

             

            thanks for your answer.

             

            Unfortunately this does not work. I can switch to RAID mode in BIOS, CTRL-i is just not available at all. When I ignore the missing RAID bios access and just continue installing Windows, I do only find ONE 8GB volume, which does not exist on the SSD anymore (yes, I load the Intel RST driver I've found in hundreds of forum discussions). It does not exist, because right now I use the whole mSATA as one single system drive with Windows 7 in it. I have the feeling that with raid mode and RST driver the windows installation tool has access to the raid controller and finds a raid configuration that is not valid anymore.

             

            Uwe

            • 3. Re: Raid defect? raid bios (RST) not accessible using ctrl-i
              kevin_intel

              I am afraid to say that images preloaded by the Computer Manufactures have special features and if enabling the RAID mode is not possible to enter CTRL-I means that this has been blocked by the manufacture.

               

              At this point, you need to contact the Computer Manufacture and confirm with them why the option room is blocked or perhaps installing the original Operating System would do the trick.

               

              Kevin M

              • 4. Re: Raid defect? raid bios (RST) not accessible using ctrl-i
                kabolz

                Hi Kevin

                 

                now it's getting interesting :-)

                Before I deleted the raids I had access to the ctrl-i raid bios. I even did the deletion with this raid tool. Then I tried to install Windows7 but it did not find any volumes. I rebooted, had no access to the ctrl-i, I rebooted again and again and suddenly (!!!) I had access again. So I created a single raid cluster. The problem is, that directly after leaving the tool this time and rebooting, the access is not possible any more, since now no chance to get in.

                 

                You wrote that I should try it with the original operating system image. Does that mean the ctrl-i tool is not a feature of the hardware, but a software component of the installed Windows and its drivers/applications? I always thought it is like with my pci raid controller in my desktop pc: I boot and I get an option to configure the raid controller, no matter whether there is an operating system or not.

                 

                Uwe

                • 5. Re: Raid defect? raid bios (RST) not accessible using ctrl-i
                  kevin_intel

                  The configuration in CTRL-I is part of hardware but sometimes OEMs have features blocked. Perhaps installing the original Operating System you can create the RAID on the Operating System using the software.

                   

                  Kevin m