1 2 3 Previous Next 35 Replies Latest reply on Aug 3, 2016 6:58 PM by Intel Corporation

    NUC won't boot after suspend - must pull cmos battery

    Breaker19

      First D5425WYK wouldn't take an OS install (multiple linux flavors: legacy and UEIF, stock and latest BIOS, multiple disk drives as well). I had continual IO errors - after dozen of hours it was clear the unit was faulty.  I held out longer than usual because I have had good experiences with Intel ethernet adapters, and their motherboards have gotten good feedback for linux compatibility and quality.  Why would it fail?  Well the NUC seems to come from a different "branch" of Intel...

       

      I RMA'd that one and tried a new unit.  I got further but still have major issues.

       

      Suspend is a key feature with the "NUC" idea that is anchored in energy efficiency.  I wanted something quiet and the NUC good for sound as long as it isn't in serious use.  Using a modern GUI the GPU fires up and the fan seems to oscillate between resting and sprint modes.  At times it is QUITE loud.  My wife is borderline hard of hearing and complained about having the unit near the kitchen.

       

      So I turn on suspend so that at least the sound issues are only when the computer is in use.  And that's where my seemingly good install goes off the rails.  Suspend is 50/50 for booting back up.  When it doesn't wake up it's 50/50 for responding to hard reboot.  If hard boot doesn't work you have to disassemble the whole unit, which isn't so easy, and pull the CMOS battery.  The CMOS battery harness in on the reverse side of the circuit board that is normally exposed from taking the case apart.  Getting to the CMOS battery is a real trick - super fun for something that will seemingly be common on this unit.

       

      Any how I pulled the CMOS battery and turned off "wake on LAN".  Lots of people are facing bricks on these NUCs and that's one of the seeming fixes.  Well I "non-booted" again after a failed suspend and after turning off WOL so I can only double fault the terrible BIOS on this unit.  Intel is on the 33rd version and it doesn't work.  So now I'm very frustrated.  I just tried live chat but it was too busy - no one to field my chat.

       

      Any how...  I'm an MIT electrical engineer with a decade of linux under my belt and two decades of system building.  I built a computer from scratch for a class in less time than I've spent on my multiple NUCs and that was literally wires and breadboard.  My impression of Intel is torched with the poor BIOS implementation here.  Intel - get on it or stop selling garbage.

       

      Why won't your NUC's boot?  I just don't get it.  I understand suspend not working... that's been tricky for the Taiwanese MB manufacturers like ASUS and Gigabyte.  I would expect Intel to get it right but to brick on suspend is a total failure.

        • 1. Re: NUC won't boot after suspend - must pull cmos battery
          joe_intel

          We appreciate your feedback in this matter.

          Intel does not test and validate Intel® NUC on Linux; however, we know that a lot of Intel® NUC owners are successfully using many different Linux distros.

          Intel suggests you check your Linux distro’s website and forums for peer assistance with this issue.

          • 2. Re: NUC won't boot after suspend - must pull cmos battery
            Apachez

            Which I find is just riddicilous.

             

            Reading through the release notes of BIOS for D54250WYK one can read this for version 0027:

             

            * Fixed issues where infrared remotes do not power on the system with OpenElec.

             

            And last time I checked OpenElec is a linuxdistro...

             

            The bricked NUC scenario has very little to do with what software is being runned on the NUC but rather bad design or construction of the NUC itself.

             

            It should simply not be possible to brick a computer by simply put it into sleepmode.

             

            If you remove the PSU power from the NUC it shall reset itself from whatever sleep mode it was in into operating as expected. Not doing so is a sign of a bug in the hardware design of the NUC.

             

            Just the placement of the BIOS battery (which is part of the troubleshooting into resetting a NUC) is a laugh in the face of NUC users, in order to remove the battery one is forced to COMPLETELY dissassemble your NUC (that is not just open the chassis, you need to unscrew it from the chassis itself to get access to the battery interface in order to disconnect it).

             

            By now Intel should be aware that are there a lot of NUCs being bricked due to sleep mode, I wonder what Intel is doing to address this bug?

            • 3. Re: NUC won't boot after suspend - must pull cmos battery
              Breaker19

              Apachez, I couldn't agree more.  I've switched off sleep in Kubuntu.  That's a temporary workaround.  I too find the official response you see above very disappointing.

               

              The NUC is sold without an operating system because Intel intended for use cases beyond light office work on MS Windows.  In particular supporting legacy boot is an obvious nod to alternative operating systems like linux.  Lots of people are excited about the NUC for XBMC/Kodi/Openelec/Plex style HTPCs and the form factor was clearly inspired by the Mac mini which was commonly used as a light server / HTPC.  Apachez, nice catch with that reference to OpenElec in BIOS release notes.  Ha!

               

              Intel - I'm still waiting for some action on this problem.

              • 4. Re: NUC won't boot after suspend - must pull cmos battery
                imwithid

                Apachez, you could not have put it better. I have just had to disconnect my CMOs batter for the sixth (6th) time. I am sick of this. Eventually, something will physically break whereby I will have to issue an RMA to Intel for their faulty product.

                 

                I don't want to hear "thank you for the feed back" or "we don't support this OS or that OS". I want to hear "thank you. we're on top of this and will fix it in the next release".

                 

                Please fix this. Find the problem, release the update. Fix it! Fix It! FIX IT!!!!!!!!!

                • 5. Re: NUC won't boot after suspend - must pull cmos battery
                  msquared

                  I am having the exact same issue. After Suspend, the NUC is bricked. I am forced to disassemble the unit, remove the CMOS battery, only then can I boot the NUC again. Please fix this issue!

                  • 6. Re: NUC won't boot after suspend - must pull cmos battery
                    _svl_

                    Same issue here. Already got one NUC replaced the first time it happened, didn't know the CMOS work around at the time so I can try that now maybe but this is unacceptable indeed... Intel, please come up with a better answer, a computer being stalled completely after suspend mode at any OS is just ridiculous.

                    • 7. Re: NUC won't boot after suspend - must pull cmos battery
                      Mgear

                      Like others are saying is true, why keep saying things are working good linux-wise ? There are a lot of problems not to say the least for the biosses. Why can't the support be intel worthy like before ?

                      • 8. Re: NUC won't boot after suspend - must pull cmos battery
                        msquared

                        I'd like to add some details:

                         

                        My NUC has worked perfectly for months, never any issues. Only when I tried to use the Suspend feature did troubles begin.

                        Upon first enabling the Suspend, the very first time my NUC went to sleep, it actually woke up perfectly fine, all I did was wiggle the mouse and it woke itself up. I was thrilled and thought Suspend works great. Then the very NEXT time it went to sleep, just wiggle the mouse did nothing, I had to actually press the Power button on NUC (which was then slowly flashing blue, as expected for Sleep).  Again it woke up, but it was annoying that just wiggle the mouse didn't work this time. Finally, on the THIRD time it went to sleep, it never woke up, despite wiggling the mouse, banging keys, pressing the power button, all the while the power button slowly flashed blue, but NUC just would not wake up. So now I unplugged the whole power supply and waited 30 seconds. Upon plugging back the power, now the NUC was bricked. The power button never went blue, just a very very dim green (or some faint color other than the normal bright blue).

                         

                        After some googling, I saw this tread and proceeded to take NUC apart, pull the CMOS battery, then reassemble. This time, plugging in lets me power up and the power button turns bright blue. I immediately disabled Suspend, and it's been working fine since.

                         

                        Problem is that for a small power friendly device like NUC, the Suspend feature is just too important to ignore. Please fix your BIOS!!

                        I will test if needed.

                        • 9. Re: NUC won't boot after suspend - must pull cmos battery
                          tkeffer

                          Exact same problem here.

                           

                          Thanks for the tip on removing the CMOS battery. It's a bitch to get at, but fixed the problem for me.

                          • 10. Re: NUC won't boot after suspend - must pull cmos battery
                            tkeffer

                            BIOS update 0038 is supposed to fix this problem. I installed it and it seems to work.

                            • 11. Re: NUC won't boot after suspend - must pull cmos battery
                              joe_intel

                              Thank you for sharing your findings with the latest BIOS tkeffer.

                              • 12. Re: NUC won't boot after suspend - must pull cmos battery
                                wolfv

                                My NUC was on BIOS Version 0040 when this happened.

                                Details on how to remove the NUC mother board to get to the BIOS battery are there: https://communities.intel.com/thread/76708

                                • 13. Re: NUC won't boot after suspend - must pull cmos battery
                                  mahsah

                                  May be they fixed this only for Ubuntu?(as per release notes) Or they reintroduced the bug it in version 0040?.  Intel say they don't test on Linux (officially) so anything is possible.

                                  I have faced this issue twice on Linux mint(ubuntu).  I have version 0040 on my NUC. I have dared to suspend only a couple of times when it worked.

                                  • 14. Re: NUC won't boot after suspend - must pull cmos battery
                                    bufke

                                    I just had this issue after updating to BIOS version 0040. Ubuntu 15.04. Version 0041 is out, going to try that out.

                                     

                                    I contacted intel live chat support but they were really unhelpful. Would appreciate if an Intel rep could at least acknowledge the issue and get someone working on it.

                                    1 2 3 Previous Next