3 Replies Latest reply on Jan 11, 2015 8:10 PM by rgb

    WiFi Instability Galileo 1st Gen

    redusk

      So I recently updated my 1st generation Galileo to version 1.0.4 using Arduino's and Intel's IDE and using the Intel supplied SD card image for WiFi. I SSH'd into my Galileo after booting it up with the SD card, turned on and set up WiFi using the wpa_passphrase (the network has WPA2 encryption) and ifup commands, and all was well. Then, I rebooted. I tried to connect again using the ifup command, and it looked like it was going to work, but, lo and behold, it didn't. The command hung right after saying "Lease of 192.xxx.x.xxx obtained, lease time 86400". I terminated the command and tried to ping google.com, but it said google.com was a bad address. I then decided to just ping my router, and that worked, oddly. It looks to me, and I could be completely wrong, that I am indeed connected to my network, but I have no DNS registries or anything past that (because of the process hanging). I decided to manually start the wpa_supplicant process using "wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf" and it gave the following output:

      Successfully initialized wpa_supplicant

      ioctl[SIOCSIWSCAN]: Device or resource busy

      wlan0: Failed to initiate AP scan

      wlan0: Trying to associate with [MAC-ADDRESS-REDACTED] (SSID='REDACTED' freq=2412 MHz)

      ioctl[SIOCSIWFREQ]: Device or resource busy

      wlan0: Association request to the driver failed

      wlan0: Associated with [MAC-ADDRESS-REDACTED-ABOVE]

      wlan0: WPA: Key negotiation completed with [MAC-ADDRESS-REDACTED-ABOVE] [PTK=CCMP GTK=TKIP]

      wlan0 CTRL-EVENT-CONNECTED - Connection to [MAC-ADDRESS-REDACTED-ABOVE] completed [id=0 id_str=]

       

      It hung there, so I terminated the process.

      Another weird thing is this: sometimes, even when I erase my SD image and start anew, it still fails. I have an Intel Centrino Wireless N-135, the mounting bracket, and the antennae that I need, and it worked on the 0.7 updates. Any suggestions?

      Thanks for your time.

        • 1. Re: WiFi Instability Galileo 1st Gen
          rgb

          I had the same problem with an Intel Centrino 2230 (Galileo Gen 2) and a Realtek RTL8188CUS USB Wireless Adaptor (Galileo Gen 1)

          Removing connman fixed it.

          But before you do, maybe you should use AlexT's version of Yocto that includes connection to his repository or manually set up a connection so you can put it back if needed.

          see Updated Galileo "devtools" image is out

          then run

          opkg remove connman

          it will hang a long time on stopping connman, but when you reboot it should be gone

          You can check with opkg list |grep connman

          rgb

          • 2. Re: WiFi Instability Galileo 1st Gen
            redusk

            Thanks a million!

            • 3. Re: WiFi Instability Galileo 1st Gen
              rgb

              I assume from your answer that this solved the problem. Since, according to AlexT and my readings, connman is just the front end for the network applications,  removing it shouldn't have any effect on your communications. I probably should also have mentioned that you can always make a copy of your SD card to your computer prior to making any major changes, so if things don't work you can just restore the previous version.

              Good luck with your project

              rgb