5 Replies Latest reply on Jan 12, 2015 5:35 AM by marblegravy

    No serial interface (was Edison stuck in boot loop)

    marblegravy

      EDIT: The boot loop was only a small issue but was the start of bad things. Now I have what appears from the blinky lights to be a perfectly fine Edison except that I have no serial interface and so can't do anything useful with it. This thread is now just a record of everything I've tried to get it working again - all to no avail. If anyone has any ideas please let me know!

       

      ---

       

      Not sure what caused this to start, but my Edison is stuck in a boot loop and I have no idea how to try and restore it.

       

      If I connect it to my mac and run screen /dev/cu.usbserial-A402IDB8 115200 -L I can see it ticking over repeating this over and over again:

       

      Screen Shot 2015-01-09 at 12.08.46 pm.png

       

      Before this started I was trying to get the wifi to work (see Help: Errors when connecting Edison to wifi).

       

      In an effort to fix the wifi connection errors, I had tried to reflash the Edison a few times from my Mac. Following the comments in Re: Updating Edison Firmware Issues I had concluded that my flashing attempts had failed as my old password was still working and plugged it in to the PC. That's when it started restarting itself over and over. Plugging it back in to the mac let me see the looping boot message in the screenshot above.

       

      So now I can't reflash because the drive never mounts, and I have absolutely no idea what to do next.

       

      Ideas please!?

        • 1. Re: Edison stuck in boot loop
          Intel_Peter

          Hello marblegravy,

           

          Is this all the log the Edison outputs before rebooting? If it isn't, could you attach the whole log?

          If you are able to see the option that says: "Hit any key to stop autoboot:  0", could you then hit any key to stop the booting and type "run do_ota ".

          Also does you computer recognize the Edison? I mean when not using the Linux console.

           

          Peter.

          • 2. Re: Edison stuck in boot loop
            marblegravy

            Thanks for your help Peter.

             

            It wasn't all of the log, but the very beginning of it disappeared off the top of the screen before I could capture it. The message above is the text that kept repeating over and over though.

             

            Now when I go to try again and get the top of the message I can't get the screen command to work!

             

            I get to screen /dev/cu. then tab and the only options are:

            cu.Bluetooth-Incoming-Port  cu.Bluetooth-Modem          cu.usbmodemfa143

             

            I've tried resetting it a bunch of times, but the usbserial option never appears.

             

            I can see the Edison drive come up though. It's there with the contents of the Yocto image:

             

            Screen Shot 2015-01-10 at 9.40.31 am.png

             

            So I'm still stuck. Though now:

            * Can't progress past step 4 - Flashing Edison on Flashing Edison (wired) - Mac because there is no usbserial available.

            * I can see the Edison drive in Finder

            * Watching the lights on the board, I don't think it's looping over and over again any more, but I'm not sure what state it is in.

            • 3. Re: Edison stuck in boot loop
              marblegravy

              I found an alternate method of flashing that I could still do on Re: How to recover Edison firmware in intel_dan's post:

              This should work on OSX (not official instructions, just what worked for me):

               

              1. Install Homebrew  by running the command

                    type/run: ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

               

              2. install dfu-util, coreutils, and gnu-getopt

                  type/run: brew install dfu-util coreutils gnu-getopt

               

              3. Download and extract Edison Image

                  download: http://downloadmirror.intel.com/24271/eng/edison-image-ww36-14.zip and double click on the zip file to extract it

                  in your terminal change to the directory where you extracted the linux image

                      (example your directory may be different) type/run: cd ~/Downloads/edison-image-ww36-14

               

              4. Run the flashall script and then plug usb cable into board

                  type/run: ./flashall.sh

               

              Note: Flashing takes a couple of minutes and there is no realtime progress meter etc.

                        when the flashing is complete you will see a message saying "U-boot & Kernel System Flash Success..."

               

              This worked (or at least it looked like it worked) however I still have no serial connection.

              Screen Shot 2015-01-10 at 3.13.31 pm.png

               

              I also didn't see the lights go out at all after this completed so not sure if it did reboot twice or not.

              • 4. Re: Edison stuck in boot loop
                marblegravy

                I reflashed it again on a PC this time and while it all went through fine and I even saw it reboot twice this time but there's still no serial interface. I suspect it's dead.

                 

                pc_flash.PNG

                • 5. Re: No serial interface (was Edison stuck in boot loop)
                  marblegravy

                  The issue appears to have been a dodgy usb cable. At least that's one of the only things I changed and now it's working!

                   

                  I believe fixing my problems was a combination of a successful flash using the PC, having power coming from the PC and data to the Mac laptop (perhaps it wasn't getting enough power when both were coming out of the same USB bus?) and swapping an older usb cable for a newer one.