5 Replies Latest reply on Dec 27, 2014 6:33 AM by Apachez

    NUC D54250WYK not recognizing USB3 external HDD after shut down

    scmikkelsen

      Hello,

       

      I got a NUC D54250WYK running Windows 7 and I am going to use it as a HTPC. I have a WD My Book 2TB 3.0 that holds all my content which is always plugged into a USB3 port.

       

      The problem I get is that after a complet shut down my WD My Book does not show up anywhere in Windows. I have checked Device Manager and also the HDD manager in windows, but it simply does not show the device at all. It is also not hidden in Device Manager, tried that also.

      I can force Windows to find the device by uninstalling/reinstalling all USB drivers and rebooting a couple of time, but nothing I have tried so far is a sure way of getting it to work.

       

      I have tried 2 different Intel USB3.0 drivers: 3.0.1.41 and 2.5.3.34. Same issue,

      All other driver on the NUC are fresh from the Intel download center, including a BIOS update.

       

      I am running out of ideas to get this working properly.

        • 1. Re: NUC D54250WYK not recognizing USB3 external HDD after shut down
          Apachez

          What if (for troubleshooting) you unplugg the drive after reboot and then replug it. Will it now show up or is it completely "dead" until you reinstall the drivers?

           

          Also try as a second troubleshooting to have the cable still connected but powercycle your WD-drive (like disconnect power to it, wait for 5 seconds or so and then reconnect power to it - unless it has a powerbutton which you can use instead).

           

          And finally how are your bios settings regarding USB, is USB Legacy Mode enabled or disabled etc?

           

          I have noticed that even if the NUC is powered off it still seems to give power on the USB interfaces which I guess might confuse devices such as the WD and other externally connected storage devices.

          1 of 1 people found this helpful
          • 2. Re: NUC D54250WYK not recognizing USB3 external HDD after shut down
            scmikkelsen

            Hi Apachez,

             

            Unplugging/replugging the device after restart does not do anything, unfortunatly. The same goes for power cycling the device.

            Basically, if windows has not already found the device (after driver reinstall or similar) replugging and power cycling do not do anything.

             

            I did do a test with BIOS USB Legacy mode on and off and every time I change it to either on or off, Windows findes an Unknown Device. If I then unplug/replug the device, it is found and working until the next time in power the NUC down and restat it then I have to do it over again.

            When poking around the BIOS I did note that the device is always found in the list of devices in the boot sequence, but when I shut down BIOS and enter Windows it is still not found.

             

            So there is a way to get it working, but its really not viable to have to go poking around the BIOS every time I restart the NUC. The old HTPC I used up until yesterday used the same WD device as storage and it would always show up on start.

            • 3. Re: NUC D54250WYK not recognizing USB3 external HDD after shut down
              Apachez

              OK, I think we then can rule out any hardwaremalfunctions (unless the BIOS of NUC does some bad magic).

               

              When you first install the drivers, are you logged in as a user with local admin privileges?

               

              To me it sounds more like an issue with Windows and its drivers rather than the hardware itself.

              • 4. Re: NUC D54250WYK not recognizing USB3 external HDD after shut down
                scmikkelsen

                That is actually a good point. Never thought about that.

                 

                So now I tried reinstalling all USB drivers using "Run as Admin" function. Windows did find the device after reboot forced by the driver reinstall but when I powered it down and restarted again to test, the device was gone again.

                 

                I also tried to rename the drive from E: to M: but no change: after restart windows does not find the device at all.

                 

                But at least it is consistent now; after reinstall of drivers and having the device unplugged and powered down during reinstall reboot, then it is always found when I plug it back in.

                • 5. Re: NUC D54250WYK not recognizing USB3 external HDD after shut down
                  Apachez

                  I tried searching for a probable fix but most seems to be to get windows to install the drivers properly as described in http://www.lovemysurface.net/usb-external-drive-not-recognized-surface-troubleshoot/

                   

                  That is remove any usb devices (which you dont really need, that is only leave keyboard and mouse in), uninstall ALL USB-related drivers (including those with explanation marks), reboot, THEN plugin the USB drive and hopefully it will fix itself.

                   

                  Other thing you can test if you use NTFS as filesystem on your drive is to first manually disconnect the drive (right click on the usb-icon close to the clock and disconnect the drive that way) before you reboot your drive and see if that change anything.

                   

                  NTFS has a "mounted" flag which if screwed up can cause the computer to refuse to mount the drive until a chkdsk is performed on it. I dont think this is it in your case but could be that the drive isnt properly dismounted and when rebooted the driver refuse to mount the drive again because it claims to already be mounted.

                   

                  A more drastic thing to test is to burn a Ubuntu 14.10 cd (or put it on usb ;-) and boot from there and see if you also have this problem when running Ubuntu (most likely not). And if this solves your problems perhaps considering switching from Windows to Linux? :-)