2 Replies Latest reply on Dec 26, 2014 4:02 PM by D@ny

    I can't install database postgresql/sqlite on my intel edison

    D@ny

      Hi, i'm newbie in this world. I was working on my raspberry pi and beagle bone black with the postgresql database and i no had problems, but in intel edison can't install postgresql, when i install it,it happens the following.

       

      root@edison:~# opkg install postgresql

      Unknown package 'postgresql'.

      Collected errors:

      * opkg_install_cmd: Cannot install package postgresql.

       

      i think postgresql it is not available on repositories. alternatively i try install sqlite, and i not have problems with the install...

       

      root@edison:~# opkg install sqlite3

      Package sqlite3 (1:3.8.3.1-r0) installed in root is up to date.

       

      ...but i have problems to execute the code in python because this can't recognize this module and i dont understand why happens.

       

      File "prueba3.py", line 2, in <module>

          import sqlite

      ImportError: No module named sqlite

       

       

      What can I do to install any database

       

      thanks