1 2 Previous Next 26 Replies Latest reply on Jan 28, 2015 2:40 PM by DiegoV_Intel

    Edison Bricked

    BuffordHumbkingle

      Hello everyone! After getting my edison, I tried to install Ubilinux for its capabilities to host a ad hoc network, but after trying, my edison board has not been working at all. When both usb cables are plugged in, I see that MERRIFIELD driver pops up and down in the device manager, and am unable to figure out why. After waiting for 1 minute, everything settles down in my device manager, but it just isnt right. Only one COM port shows up, and not the one used to program arduino even though I have both cables plugged in! I tried connecting to the Edison board through Putty, but nothing happens. Is there any way that I can fix this, or do I have to get another one? Thanks again.

       

      -Bufford Humbkingle

        • 1. Re: Edison Bricked
          pabu

          refer to this cannot use USB in Ubuntu 14.10 w/ Edision

           

          It looks like you are using Windows host?

           

          Although this link points to a question about a Ubuntu host, it may still apply. You may want to try going thru a hub. I haven't tried on Windows.

          • 2. Re: Edison Bricked
            CMata_Intel

            Hi BuffordHumbkingle ;

             

            Have you been able to work with your USB ports, the COM and Serial?

             

            Regards;

            CMata

            • 3. Re: Edison Bricked
              BuffordHumbkingle

              There is a COM port open, but is not meant for programming through, rather connecting through it using Putty, even though I have connected both usb cables to my computer. I tried to use a Ubuntu computer to flash the default Linux distribution on the board, but it couldn't connect to the Edison. In the device manager, I see that there is a "Merryfield" device not having a driver, but then goes away all of a sudden and disconnects from my computer when plugging in the Edison to my computer. Is there any way to reset the board and erase its storage directly on the board or do we have to connect to it and flash it via a host computer? Thanks anyways.

              -Bufford

              • 4. Re: Edison Bricked
                AlexT_Intel

                First thing to check here is where exactly it fails. That means you need to connect to the serial console - which is on the micro-USB port at the edge of the board (either Arduino or mini-breakout). Don't connect the second USB port (unless you're powering the board that way), it's irrelevant at this step.

                 

                After that connect to the console using Putty or other terminal client, specific instructions could be found in e.g. Quick Start Guide. Connecting to this port requires FTDI driver to be installed, so if you haven't done this before, you may need to do this now - again Quick Start Guide is the best source here.

                 

                After connecting to the serial console, capture the output of the complete board reset process and post here - that would be a good first step to check what's going on there.

                • 5. Re: Edison Bricked
                  BuffordHumbkingle

                  Hello AlexT,

                   

                  I already have installed all the drivers for the edison. It used to work, but after installing Ubilinux onto the Edison, it seems to have gone throuh all of this trouble. The weirdest part is, is that after installing Ubilinux, it still seems to be holding Yocto as its OS.

                   

                  -Bufford

                  • 6. Re: Edison Bricked
                    AlexT_Intel

                    There may be several explanatons to the situation you describe, because the description is a bit too generic That's why I'm asking for the console log - that will show everything.

                    • 7. Re: Edison Bricked
                      BuffordHumbkingle

                      This is a screen recording of the Putty Window and Device manager.

                      -Bufford Humbkingle

                      • 8. Re: Edison Bricked
                        AlexT_Intel

                        Okay, nice way of presenting several things at once

                         

                        All in all, I can say after watching that:

                        1. Your Edison is fine and definitely not bricked [any more] as long as you can boot it and see the Linux console;
                        2. Out of the directory listings it would look like it's actually booting the Yocto-built Linux, is that the case? Have you reflashed the board or something? Check the output of "cat /etc/version" to check this out;
                        3. The fact that you don't see the additional virtual devices for uploading sketches may mean that either you don't have necessary drivers installed on your PC or that the necessary drivers don't load on Edison itself. To check the former, make sure you've installed the driver from here:http://downloadmirror.intel.com/24271/eng/IntelEdisonDriverSetup1.0.0.exe, to check the latter please post the output of "lsmod" command + the output of "journalctl -x --no-pager" (this one will be long);
                        • 9. Re: Edison Bricked
                          BuffordHumbkingle

                          Thanks for replying AlexT_Intel,

                           

                          I am not sure how to do what your saying. What I did was I ran the command journalctl -x --no-pager" and got a bunch of text, and then put it inside of a file, but I do not know how to do the lsmod command that you want me to do. should I pipe the output of the "journalctl -x --no-pager" command into the "lsmod" command, because I tried that and it would not work. Oh and yes, when trying to flash into Ubilinux a while ago, it did not seem to have done anything, because as you saw in the video, the Edison is still using Yocto. Anyways thanks alot.


                          -Bufford Humbkingle

                          • 10. Re: Edison Bricked
                            AlexT_Intel

                            Okay, so step by step:

                             

                            1. Being logged on on your Edison's serial console using PuTTY (like on yor video) run (which means, copy the command->paste it into the console->press Enter) "journalctl -x --no-pager"
                            2. After that run "lsmod"
                            3. After that left-click on PuTTY's window menu icon (see screenshot below) and select "Copy All to Clipboard"
                            4. After that paste that into any text editor, save as a text file and post here

                             

                            • 11. Re: Edison Bricked
                              BuffordHumbkingle

                              So I went into the Edison board and logged on and followed all the commands, but the problem that I had noticed was that there were too many lines for the output of the first command that Putty could not get back, so truthfully, what is on the txt file, is not everything that was being spilled out by that first command.

                               

                              -Bufford

                              • 12. Re: Edison Bricked
                                BuffordHumbkingle

                                Never mind AlexT,

                                I figured out how to modify the scroll buffer size.

                                Here is the txt file.

                                Dropbox - edison log.txt

                                 

                                -Bufford

                                • 13. Re: Edison Bricked
                                  AlexT_Intel

                                  Okay, so something is apparently wrong there - lsmod shows no modules loaded, which is wrong and this

                                  Oct 09 09:44:33 inteledison launcher.sh[156]: /opt/edison/launcher.sh: line 20: can't open /dev/ttyGS0: no such file

                                  is an additional specific sign that the cdc-acm driver (the one that creates that USB link to IDE, among other things) isn't loaded as well.

                                   

                                  At this point I'd suggest you to reflash the board using the flashall.bat/flashall.sh way (i.e. non-OTA), as it's the most robust way to do that, though it requires some experience - so let's try one more thing first.

                                   

                                  Try out these instructions: Flashing Edison (WiFi) - Windows and let's see if that works. To be honest I doubt it would given the state of the system, but let's see.

                                  • 14. Re: Edison Bricked
                                    BuffordHumbkingle

                                    Hello AlexT,

                                     

                                    Can you guide me into doing this, because after downloading the flashall.bat file with a bunch of other files, it is telling me to install the xFSTK downloader which is only available in Linux. If you can explain to me the same way you did in your previous post, I would be very greatful . Thanks again.

                                     

                                    -Bufford

                                    1 2 Previous Next