3 Replies Latest reply on Dec 21, 2014 1:29 AM by tinezi

    DN2820FYKH - All methods of updating BIOS fails, unable to install Windows

    tinezi

      Hello,

      I decided to start a new thread instead of replying to this one Re: DN2820FYKH - Unable to update BIOS

      My NUC setup:

       

      1 x INTEL NUC DN2820FYKH Celeron N2820 1xDDR3L SO-DIMM 1xSATA 2.5in  (BOXDN2820FYKH0)

      1 x Crucial 256GB MX100 2.5" SSD MLC SATA III 550/330MB/s (CT256MX100SSD1)

      1 x KINGSTON 4GB 1600MHz DDR3L Non-ECC CL11 (KVR16LS11/4)


      I bought DN2820FYKH and tried to install Windows 7 from usb stick.

      I downloaded official ISO from Microsoft http://www.techverse.net/download-windows-7-iso-x86-x64-microsofts-official-servers/

      Then I created bootable USB stick according to this guide: http://www.techverse.net/how-to-create-a-bootable-usb-pen-drive-for-windows-7/

      I also tried two another programs due to the issue I couldn't install Windows 7.

       

      Then I read I have to update BIOS from here: Intel® NUC — Operating System Installation

       

      Every method of updating ends with error, that can be seen in the image. "Flash update fails"

       

      I copied the FY0045.bio file to FAT32 formatted empty USB stick and tried to update by pressing F7 on boot and selecting file, didn't work.

      I tried FY0041, FY0025, FY0021, didn't work.

      I created bootable USB stick and tried to flash using iflash.exe, didn't work.

      I tried updating via Visual BIOS, via direct internet connection, Error about not finding Product ID.

      I tried updating via Visual BIOS from USB Stick, didn't work.

      I tried updating via BIOS Recovery Update using this guide, didn't work (caused boot loop) Intel® NUC Boards and Kits — BIOS Recovery Update Instructions

       

      And most of those methods I tried with three(!) different USB stick I had...

       

      I really don't know what I can do more, please help me!