2 Replies Latest reply on Dec 21, 2014 1:19 PM by N.Scott.Pearson

    DN2820FYK's can't disable usb optimization

    Emanuel

      I have bought in may this year a DN2820FYK NUC. I have installed 8GB RAM and a 2.5' hard-drive.

      At the beginning, I had problems with the NUC booting when I had USB storage connected to it.

      Since I liked it and the price, I decided to make it work, and enabled USB optimization. This solved the problem, although it was still hanging in windows withe the USB storage attached (it had something to do with the usb drivers/ports/hardware).

      Fast forward this week. My harddrive crashed and I had to replace it. Bought a new one, but can't managed to get into the BIOS to disable the USB optimization and enable USB booting.

       

      Tried everything:

       

      1) Moving the jumper

      2) removing the jumper

      3) removing the bios battery

      4) Updated to the latest bios (by removing the jumper and waiting with a usb flash connected)

      5) Downgrade to BIOS 0015 (same way as above)

      6) Powered the NUC on and then  repressed and kept the power button. after 2 sec the NUC turned off. Never heard the 3 beeps as I have read around

      7) Powered the NUC and kept pressing the button. same think as above happened

      8) power on the NUC and the unplugged the AC

       

      None of them worked for disabling that stupid USB optimization.

      Does anyone have any solution. I really regret buying this, especially since I bought it in Denmark from a store there and now I moved and I have to ship it there from Romania.

       

      P.S. I tried both wired and wireless keyboard and none of them respond to buttons.