2 Replies Latest reply on Jun 6, 2015 1:48 AM by johnnyxiong

    edison kernel modification seems not work

    johnnyxiong

      I run :

      1,  source poky/oe-init-build-env

      2.  bitbake virtual/kernel -c menuconfig

      3.  cp tmp/work/edison-poky-linux/linux-yocto/3.10.17+gitAUTOINC+6ad20f049a_c03195ed6e-r0/linux-edison-standard-build/.config tmp/work/edison-poky-linux/linux-yocto/3.10.17+gitAUTOINC+6ad20f049a_c03195ed6e-r0/linux/arch/x86/configs/i386_edison_defconfig

      4. bitbake virtual/kernel -c configure -f -v

      5. bitbake edison-image

      6. ../device-software/utils/flash/postBuild.sh

      then I flash edison in windows, as :

      1. copy the toFlash/* to the disk mapping in windows by edison

      2. putty edison

      3. reboot ota

       

      but I find that the kernel seems not changed:

      1. after  bitbake virtual/kernel -c configure -f -v, I do bitbake virtual/kernel -c menuconfig again and find that the modification I made changing back.

      2. for a test, I cancel the selection of drivers->watchdog timer by  bitbake virtual/kernel -c menuconfig, but after flashing in windows, I putty on edison, ls /dev, the watchdog still there!

       

      I do the steps following the instructions of edison-bsp_ug_331188-001.pdf, so how should I do kernel modification and make them affect? and what's the meaning of virtual/kernel ?

       

      Any helps I appreciated, thanks!

       

      johnny

       

       

      Thank you mhahn for your reply. I can't move the old published question to this forum, so I write a new one.

       

      This is the reply by mhahn, thank you!

       

      wrong subforum - seems targetted towards Edison ...

       

      if it's only about kernel modification there is no need to build a complete new image. See e.g. [SOLVED] Best way to clean, rebuild kernel