13 Replies Latest reply on Dec 10, 2014 10:40 AM by deium

    Password Problem

    Rufous

      Kind of an embarrassing question, but I just got the Intel Edison Starter Pack from Sparkfun.  I went through the setup with the only problem being that I often had my first keystroke after any period of inaction ignored by the Edison.  Whether or not that's responsible for my problem, I'm not sure. 

       

      My problem:  I can't log in.  It's only been about 380 seconds since I made my password and it's a password I use often, so the odds that I'm simply forgetting the password are slim to none.  Yet I now cannot login to the Edison.  I'm wondering if it has to do with the problem with the Edison not registering my first keystroke after any period of inaction.  So of course I tried the password minus the first letter - nothing seemed to work. 

       

      Has anyone else had this problem?  It seems pretty fundamental.  You make a password.  You use the password.  How could that possibly go wrong?  Anyway, if nobody else has had this problem then I'll reflash and pretend like this never happened, but it's bugging me enough to wonder if this is a software problem. 

        • 1. Re: Password Problem
          deium

          This problem has happened to others.  Did you flash your Edison with the latest image, or is it the factory image onboard?

          • 2. Re: Password Problem
            Rufous

            No way!  It's happened to other people?  It's the factory image.  I just took it out of the box, went through the startup dialogue and... now maybe this is my mistake (?)... I disconnected the USB cable.  When I reconnected it, I couldn't log back in.  If it matters at all, I'm running Ubuntu 12.04 on my laptop. 

            • 3. Re: Password Problem
              deium

              If you remember "your password", the factory image would truncate the first characters on the serial UART (which you had connect via USB).  It is possible that if there was a long enough delay between when you put your password in, it could be that your password was recorded as "our password".  One thing to try.

               

              best course of action is to download the lastest imageEdison - Software Downloads so that you can flash your Edison to the latest version - flashing also clears the password.

               

              Please read the links provided in the thread below - the threads will assist you if you stuck.

              https://communities.intel.com/message/267482#267482

              • 4. Re: Password Problem
                b1tninja

                my understanding is the first character may be dropped after inactivity, if settings for hardware flow control aren't set properly, perhaps try your password minus the first character.

                • 5. Re: Password Problem
                  deium

                  yes, that is what  was getting at.  The factory image was flawed in that regardless of hardware settings the first character was dropped as the UART went into sleep mode prematurely.

                  • 6. Re: Password Problem
                    deium

                    that UART flaw of course, was fixed in next image, and the latest image.

                    • 7. Re: Password Problem
                      Rufous

                      Thanks for all the help.  Yeah I've tried the password without the first character and that doesn't work.  I'll try figuring out how to flash with the latest image.  I have literally no idea how to do that given that I'm working with the Sparkfun Stack but I'll give it a go.

                      • 8. Re: Password Problem
                        mhahn

                        There is a description of how to run "reboot ota" in another thread

                        • 9. Re: Password Problem
                          mhahn

                          I mean from within Yocto

                          • 10. Re: Password Problem
                            deium

                            keep us informed through this post, I too am curious how the sparkfun stack works out.

                            • 11. Re: Password Problem
                              Rufous

                              Sure, I didn't have time to flash the latest image last night.  I'll give it a go tonight and post the results.  I'm curious if the UART issue continues even after that.

                               

                              Thanks again for your help.

                              • 12. Re: Password Problem
                                Rufous

                                Okay, so I thought I'd give you another update.  Here's the story as I can figure it out:

                                 

                                1.  There's a bug in the Sparkfun Console Block that causes the first typed character to get dropped from time to time.

                                2.  If you're unlucky enough to have that bug mess up your login credentials, then you're up a creek without a paddle because...

                                3.  You cannot flash the Intel Edison using only the Sparkfun Console Block despite that block being part of their "Intel Edison Starter Pack." 

                                 

                                So, as far as I can tell, my only option is to shell out another $30 for the Sparkfun Base Block.  Without that block, the Intel Edison's firmware apparently can't be updated.  It seems like that functionality should be included in anything masquerading as a "starter pack" but oh well.  With any luck, I can get the Base Block, flash the newest Yocto image and hope that the "solution" to the next bug isn't a purchase of, say, the 9-DOF Block from Sparkfun.

                                • 13. Re: Password Problem
                                  deium

                                  Rufous,

                                  1) That bug is with the Edison module UART and not addressed in the default factory image - was corrected in image updates.

                                  The difficulty is that the sparkfun not included base block leaves you with no method to update the firmware.

                                  Thanks for the update.