2 Replies Latest reply on Dec 11, 2014 10:10 AM by deium

    Counldn't resolve host, how to reset the wifi?

    CasperSL

      Hi guys,

       

      I connected edison to my iPhone hotspot via wifi the other day,

      it worked fine and I could download / install things on edison.

       

      Then, when I tried to install something with npm today, it keeps saying

       

      getaddrinfo ENOTFOUND

       

      I guess this is related to dns or host or something similar? So I googled..

       

      I tried to ping www.google.com on edison, it says bad address,

      Ping 74.125.24.103, it works.

       

      I tried to curl http://registry.npmjs.org/npm, it says,

      curl: (6) Couldn't resolve host 'registry.npmjs.org'

       

      I tried to change /etc/resolv.conf, to add some dns server there,

      but I don't know how I can get this file persisted on disk, right now I can not save my changes.

       

      So now I wonder is there any way to reset the wifi configuration completely?

      to reconfigure everything, including the ability for edison to resolve hostnames.

       

      I tried configure_edison --wifi, still it doesn't resolve hostnames.

       

      my edison version is:

      edison-rel1-maint-weekly_build_16_2014-10-14_14-56-19


      Thanks!

      -Casper