1 Reply Latest reply on Mar 13, 2015 11:10 AM by DiegoV_Intel

    Help in executing opencv binary on galileo debian 1.2 image

    abhishek_thakur

      hi I am working on my galileo board with the debian 1.2 image on it. I am new to linux so am not good in commands. I have installed the image on an sd card using win32disk manager and it runs good on galileo. I on booting the image ssh into it through the ip and then tried to run :

      aptitude update

      aptitude upgrade

      On the first go this works fine but after this if i run aptitude it gives segmentation fault and the setup stops.

      ---------------------------------------------------------------------------------------------------------------------------------------------------------------------

      root@galileo:/home# aptitude upgrade

      The following packages will be REMOVED:

        sgml-base{u}

      0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.

      Need to get 0 B of archives. After unpacking 116 kB will be freed.

      Do you want to continue? [Y/n/?] y

      (Reading database ... 32293 files and directories currently installed.)

      Removing sgml-base ...

      Processing triggers for man-db ...

      Segmentation fault

      --------------------------------------------------------------------------------------------------------------------------------------------------------------------------

       

      apt-get runs smoothly which is why i was able to install opencv libraries on the board using:

      apt-get install libopencv-dev

      This is how i managed to install opencv on the board. I made a sample program for opencv and compiled it through :

      g++ `pkg-config opencv --cflags --libs` try1.c -o try1

      The compilation is successful which gives the try1 binary. For executing the binary i ran :

      ./try1

      But everytime i do this i get this error :

      Illegal instruction

      I installed gdb and ran the binary there and got the following:

      -------------------------------------------------------------------------------------------------------------------------------

      GNU gdb (GDB) 7.4.1-debian

      Copyright (C) 2012 Free Software Foundation, Inc.

      License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>

      This is free software: you are free to change and redistribute it.

      There is NO WARRANTY, to the extent permitted by law.  Type "show copying"

      and "show warranty" for details.

      This GDB was configured as "i486-linux-gnu".

      For bug reporting instructions, please see:

      <http://www.gnu.org/software/gdb/bugs/>.

      (gdb) exec try1

      (gdb) run

      Starting program: /home/try1

      [Thread debugging using libthread_db enabled]

      Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".

       

       

      Program received signal SIGILL, Illegal instruction.

      0xb74dde01 in ?? () from /usr/lib/libtbb.so.2

      (gdb)

      -----------------------------------------------------------------------------------------------------------------------------------

       

      Thankyou

      Abhishek