13 Replies Latest reply on Dec 10, 2014 7:42 PM by jblackston

    Updating Edison Firmware Issues

    jblackston

      I have two Edison boards running on the arduino boards. The first one I was able to perform the windows flash update no problem and the board took it fine. One way of verifying it the configure_edison had the latest versions. I have been working on that board for a while and now I'm trying to setup the second Edison board for a prototype.

       

      Ok a few odd things I've run into that I can't explain. When i grab the second Edison and connect it to my PC and try and run the terminal to it, to this arduino's COM port, it doesn't want to connect. The terminal program finds the com port but when you hit enter nothing on the terminal shows up. I do get the removable drive to show up. If I move the Edison to my first arduino board (switching the COM port again) and power up everything works and connects. I copy the new firmware files over and then issue the reboot ota command and wait. After it finishes I go back to try and run configure_edison to see if it's updated and it's not, its still running the old version.

       

      Any ideas?

        • 1. Re: Updating Edison Firmware Issues
          Intel_Peter

          Hello jblackston,

           

          There's a few things I need you to do:

           

          1. What we need first is to discard the second Arduino expansion board, so try to enter the Linux shell with the first Edison and the second Arduino expansion board. This way we could discard one variable so we can focus on the main issue. Please tell us what happens.

          2. Connect the second Edison to your computer. Check the letter assigned to the Edison(D:, E:, F:...). Open CMD and type that letter “X:”. Type “dir” and send me a screenshot of whatever it displays.

          3. Now please try to flash again the second Edison and send me a screenshot of the error it displays or if it doesn't show an error, please attach the log.

          3.1. Try using other USB cables, I know it sounds silly since you managed to flash the first Edison with them but it could help.

          3.2. Use USB 2.0 Ports, 3.0 Ports could cause issues.

           

          Please tell us how it turns out.

           

          Regards,

                      Peter.

          • 3. Re: Updating Edison Firmware Issues
            jblackston

            The file list in the DIR command prompt is the files that are located in the WW42-14 yocto zip file, that gets placed in the removable drive on the Edison. When performing a the flashall.bat the message I get is a can't find 'dfu-util' not recognized. When I perform a 'reboot ota' via the terminal like in the (wired) windows instructions it preform a reboot and seems like it's performing an update, but once I run log in after the reboot it doesn't seem like things have changed. The 'reboot ota' command is also what I used on the previous Edison board and that worked out fine.

             

            The USB cables are the same ones that I was able to do on the first Edison board I received. I did go ahead and run a different cable same result.

            • 4. Re: Updating Edison Firmware Issues
              Intel_Peter

              Hello jblackston,

               

              I just check my Edison and take a look at this:

               

              dirlog.PNG

               

              We don't get the same output when we type "dir", you are missing one directory, what I'm thinking is, something might have gone wrong when you decompressed the files on your Edison, try re-downloading/decompressing the  image again and try to flash it one more time.

               

              Regards,

                          Peter

              • 5. Re: Updating Edison Firmware Issues
                jblackston

                I redownloaded the edison-image-rel1-maint-rel1-ww42-14 file and this is what I get, the same as what my directory showed. Am I downloading the right file? It's the same file I used on my other board.

                • 6. Re: Updating Edison Firmware Issues
                  Intel_Peter

                  Hello jblackston,

                   

                  I'm sorry I was the one with an extra directory, I have a couple of questions:

                  1. Are you using a power supply or just the two USB cables?

                  2. Were you able to use the second Arduino expansion board correctly with the first Edison?

                   

                  Regards,

                              Peter

                  • 7. Re: Updating Edison Firmware Issues
                    deium

                    jblackston, the ww42 firmware does complete the flash, but does not clear the ota drive or the contents of /home/root.

                     

                    Although the ww36 firmware did clear all space, I might not be considered a bug, but rather a valuable feature.

                    For me, it allows me to have the ww42 image on the ota drive so I can reset at anytime I want (reboot ota), and allows me to persist particular settings, and files by saving them to a section of the /home/root directory before flashing, and then replacing the settings after the reboot ota has completed.

                     

                    To answer your question, the flashing has occurred, and can be confirmed with /etc/version.

                    • 8. Re: Updating Edison Firmware Issues
                      deium

                      Intel_Peter,

                      in your DIR, I don't get a boot directory either.  Is this boot a directory one created in the ota drive previously, as the ota drive doesn't clear on the ww42 image.

                      • 9. Re: Updating Edison Firmware Issues
                        jblackston

                        • 10. Re: Updating Edison Firmware Issues
                          deium

                          jblackston,

                          If your first login after flashing (reboot ota) isn't root without a password, that would be a tell tale sign the flash did not complete - for what ever reason.

                          The only recourse, repopulate the ota drive with the lastest firmware and reissue the reboot ota.

                          If still failing, do a full format to fat32 on the ota drive (not a fast format), and retry.

                          • 11. Re: Updating Edison Firmware Issues
                            jblackston

                            Ok, I'll try and reformat the OTA drive and repopulate it with the latest WW42 firmware and retry the update.

                            • 12. Re: Updating Edison Firmware Issues
                              deium

                              jblackston, let me know when it works.

                              • 13. Re: Updating Edison Firmware Issues
                                jblackston

                                Yup that did the trick. I just went on windows on did a full format on the OTA drive and reloaded it and ran 'reboot ota' and it worked. Thanks.