4 Replies Latest reply on Jan 15, 2015 1:49 AM by NintendoManiac64

    [Haswell iGPU] Cannot use custom refresh rate as default; keeps defaulting to 75hz

    NintendoManiac64

      Hardware is Pentium G3258 and GPU is its Haswell Intel HD integrated graphics, OS is Windows 7 64bit SP1.  Driver installed was the newest 15.36.7.3960, but in the Intel graphics "Information Center" it lists the version as 10.18.10.3960

       

       

      No matter my GPU vendor, by default I can only select up to 75hz on my display even though it's capable of over 120hz at 640x480 and over 90hz at 1280x720.  Therefore I've set up a few custom refresh rates at a variety of resolutions:

       

      800x600 @ 112hz

      1024x768 @ 88hz

      1152x864 @ 79hz

       

      However, whenever I select those resolutions, whether through windows or via a game, it always runs at 75hz instead of my custom resolution.  If I look at the refresh rates available via "Advanced Settings" in Windows 7's "Screen Resolution", I can see that the custom refresh rate is indeed available, but I have to go into said "Anvanced Settings" and manually select it every single time I change my resolution - this is particularly annoying for fullscreen games that lack refresh rate selection (which is many) where I have to first manually change my desktop resolution and refresh rate to what I want the game to run at, and then launch the game; afterwards I then have to manually set my desktop resolution and refresh rate back to what I had before.

       

      Now to clarify, when I do manually select those custom refresh rates and their according resolution, the image displays perfectly - my monitor is fully capable of handling those refresh rates at those resolutions and the monitor's menu confirms that it's accepting and displaying the according refresh rate and resolution.

       

       

      Oddly enough though, setting a custom resolution for 640x480 @ 120hz does have it run at 120hz for any 640x480 fullscreen games, which is what I would expect for the other resolutions.  Though oddly again, setting 640x480 compatibility mode in Windows results in running at 60hz...

       

      Now if it's a custom resolution that Windows considers to be larger than 1152x864, such as 1280x704 @ 96hz, then you will always get 96hz whenever you select 1280x704 in anything whether it's a game or the desktop resolution or whatever.

       

       

      And for reference, checking and/or unchecking "Hide modes that this monitor cannot display" doesn't change the issue.

        • 1. Re: [Haswell iGPU] Cannot use custom refresh rate as default; keeps defaulting to 75hz
          joe_intel

          Do you know if this was working properly before? If yes, do you remember the driver version that worked? You also try the driver version provided by the system manufacturer.

          Can you provide the Intel® HD Graphics report and monitor model?

          Graphics Drivers — Intel® Graphics Driver Report

          1 of 1 people found this helpful
          • 2. Re: [Haswell iGPU] Cannot use custom refresh rate as default; keeps defaulting to 75hz
            NintendoManiac64

            As this is a new PC build (only 10 days old), no it has never worked.

             

            Interesting thing though, if my desktop resolution is set to 1024x768 @ 88hz, then when I launch a game at 800x600, it runs at 60hz.  If my desktop resolution is set to 1024x768 @ 85hz, then when I launch the same 800x600 game, it runs at 85hz... (and not, it's not a quirk with that specific game)

             

             

            EDIT: After doing that testing, any game in fullscreen at 800x600 now wants to run at 60hz instead of 75hz...

             

            EDIT 2: I was able to get 800x600 running at 75hz again by deleting my 800x600 @ 112hz custom resolution, rebooting, adding a custom resolution of 800x600 @ 85hz, and then finally rebooting again.  Once 800x600 @ 75hz was working again, I was able to delete my custom 800x600 @ 85hz without consiquence and was even able to add my original 800x600 @ 112hz back in.

             

            EDIT 3: I re-created the 60hz issue and tried the steps in my "EDIT 2" to see how repeatable it is, but it didn't work this time...now I'm stuck with 60hz for 800x600.  It may have been because I tried a custom resolution of 800x600 @ 75hz instead of 85hz to see if that would also work (it did not).  Now I do know that if I re-install the graphics drivers, things will go back to defaulting to 75hz rather than 60hz.

             

            EDIT 4: Here's something interesting, those 800x600 fullscreen games of mine will always run at 60/75hz unless my desktop resolution (if not set to 800x600) has a refresh rate of 70hz, 72hz, 75hz, or 85hz.  If I use any of those as my desktop refresh rate, then regardless of the resolution of my desktop, any 800x600 fullscreen games will run at that same refresh rate.

             

            EDIT 5: I think I've figured out why a custom resolution and refresh rate of 640x480 @ 120hz works - it would seem that, 60hz, 70hz, 72hz, 75hz, 85hz, and 120hz are all refresh rates that the Intel graphics drivers deem "acceptable" for use.   I say this because if I change the refresh rate for my 640x480 custom resolution from 120hz to 144hz, then any 640x480 fullscreen games will instead run at 75hz, just like what was happening with the 800x600 fullscreen games.  Note that I also tested 90hz, 96hz, and 100hz, but none of those were considered "acceptable" because 640x480 fullscreen games were still running at 75hz.

            • 3. Re: [Haswell iGPU] Cannot use custom refresh rate as default; keeps defaulting to 75hz
              NintendoManiac64

              Apologies for taking a week to directly answer your question, but I had hunch that the issue I was having was independent of my monitor...so I tested it on 4 different displays, one of which supported two different inputs:

               

              Toshiba 39L1350U (LCD, VGA & HDMI)

              X2gen MG19MY (LCD, VGA)

              ADi MicroScan GD-780T (CRT, VGA)

              Dell E772p (CRT, VGA)

               

              The test was simple, make two custom resolutions that all 4 displays were capable of displaying (as confirmed by their on-screen display):

               

              800x600 77hz 32bit GTF

              1024x768 64hz 32bit GTF

               

              After entering those custom resolutions, I rebooted.

               

              I then manually changed my desktop to 800x600 @ 77hz to confirm that it worked, and it did on every display (all 4 showed 77hz on their OSD).

               

              Then I changed my desktop again to 1024x768 @ 64hz, and again, on all 4 displays, the OSD confirmed that I they were displaying at 64hz.

               

              Lastly, I launched a fullscreen 800x600 game, and sure enough, every display then ran at either 800x600 @ 75hz or 800x600 @ 60hz.

               

               

              (and BTW, the iGPU wasn't outputting 4:4:4 chroma over HDMI @ 1920x1080 60hz but did do 4:4:4 chroma at 1360x768 60hz and 1280x1024 60hz along with 4:4:4 over VGA @ 1920x1080 60hz, but that's not really within the scope of this thread)

               

               

              As for a graphics report, I'm not sure if this is the right thing, but we'll see.  Note that this was saved while connected to the last monitor used (the Dell E772p):

              Intel GPU drivers - Dell E772p - Pastebin.com

              DxDiag 32bit - Dell E772p - Pastebin.com

              DxDiag 64bit - Dell E772p - Pastebin.com