2 Replies Latest reply on Dec 2, 2014 8:56 AM by MasterShogo

    Intel P3700 PCIe 800GB SSD does not work with CentOS 6.6 or 6.5, but does work with 7.0.

    MasterShogo

      I am running a new P3700 800GB SSD in the primary 16x PCIe graphics slot in a new Dell precision T1700 workstation. I started off trying CentOS 6.5 and 6.6, but I could not format it with either. I started out trying the GUI disk management tool and it would just hang when I attempted to modify the drive. Then, I tried "parted" and "mkfs" to partition and format the disk. When I attempted to create the partition, it hangs and then exits with IO errors, at which point the entire device is no longer visible with "lspci" anymore. When I loaded CentOS 7.0, it worked fine; partitioning, formatting, and general use. This confused me a bit, since 6.5 was supposed to support nvme and 6.6 reported nvme driver version 0.9 with modinfo, whereas CentOS 7.0 reports nvme version 0.8. This was reproducible with a second P3700.

       

      Is there a known issue with this drive and the 2.6.32-x kernel used in Red Hat 6? I haven't gone looking through any kernel logs, but I wasn't even sure if the mainline upstream kernel 2.6.32 even had this driver in it or if it was added by Red Hat. Thanks for any insights.