7 Replies Latest reply on Jan 7, 2015 11:39 AM by AlexT_Intel

    Installing opencv on Intel Galileo

    prakharsingh95

      Hi,

       

      I am trying to run opencv on Intel Galileo Gen 1. I am using the standard SDcard image provided by intel. opencv package was preinstalled an I updated it via opkg. However, it gives me this error

       

      Python 2.7.3 (default, Aug 19 2014, 18:31:31)

      [GCC 4.7.2] on linux2

      Type "help", "copyright", "credits" or "license" for more information.

      >>> import cv2

       

       

      /usr/bin/python2.7: symbol 'th_comment_query_count': can't resolve symbol in lib '/usr/lib/libtheoraenc.so.1'.

      Traceback (most recent call last):

        File "<stdin>", line 1, in <module>

      ImportError: unknown dlopen() error

      >>>

       

      I read that opencv can work by replacing ulibc, and going to this blog (Intel Galileo - Building Linux Image - Malinov Family Web Presence), I tried to compile my one image. Howerver, the link for the file Intel® Download Center is not up.

        • 2. Re: Installing opencv on Intel Galileo
          CMata_Intel

          Hi prakharsingh95 ;

           

          I just entered in Intel® Download Center and I was able to download the package, please try again and let me know if it doesn't work for you.

          I found this thread related to a compilation error, but the installation of the packages worked in that case. You could replicate the process, this is the website that will help you to install the packages that you need. If you click in the Package repo directory index (under Galileo package repo configuration) you will access the link mentioned in that thread.

           

          Regards;

          CMata

          • 3. Re: Installing opencv on Intel Galileo
            prakharsingh95

            Hi CMata_Intel,

             

            Thanks for replying. I have tried multiple browsers, but that link doesn't seem to be working (I am in India). I click on "I accept the terms of the agreement" and nothing happens. I have tried multiple browsers.

             

            Can you please post a link for a mirror?

            • 4. Re: Installing opencv on Intel Galileo
              CMata_Intel

              I'm not sure the reason of why you are not able to download the files in that link. Do you have the pop-ups blocked in your browsers? (If so, Un-blocked them)

              Also, I saw that the link that you are using makes a reference to https://communities.intel.com/community/makers/software/drivers and the package is not there and the latest update in the blog is in October 2013. So I can suggest you to follow Quark BSP Build and Software User Guide to create your image. In that tutorial the files that are used are Board Support Package 1 and 2.

              Let me know if the pop-ups alternative works, and take a look at the document it could be helpful

               

              Regards;

              CMata

              • 5. Re: Installing opencv on Intel Galileo
                AlexT_Intel

                prakharsingh95, I saw your email you've sent me via my web site. Generally speaking, CMata_Intel is correct, there must be something wrong with your browser, because all the downloads are there and working fine. Check JavaScript or popup blockers in your browser, for starters.

                • 6. Re: Installing opencv on Intel Galileo
                  Jackie-MCG

                  Hi

                  I have try you method follow above step.But there is some error when i build the full image. Can you help me to fix it.

                   

                  Thanks

                  Zhe

                   

                   

                  bitbake image-full

                   

                  error log is:

                  WARNING: Failed to fetch URL http://argparse.googlecode.com/files/argparse-1.2.1.ta                                                                                                                  r.gz, attempting MIRRORS if available
                  WARNING: Failed to fetch URL ftp://ftp.freedesktop.org/pub/mesa/9.0.2/MesaLib-9.0.2                                                                                                                  .tar.bz2, attempting MIRRORS if available
                  WARNING: Failed to fetch URL http://liba52.sourceforge.net/files/a52dec-0.7.4.tar.g                                                                                                                  z, attempting MIRRORS if available
                  WARNING: Failed to fetch URL http://webm.googlecode.com/files/libvpx-v0.9.5.tar.bz2                                                                                                                  , attempting MIRRORS if available
                  ERROR: Fetcher failure: Fetch command failed with exit code 4, output:
                  Read error (Connection timed out) in headers.
                  Read error (Connection timed out) in headers.

                  ERROR: Function failed: Fetcher failure for URL: 'http://webm.googlecode.com/files/                                                                                                                  libvpx-v0.9.5.tar.bz2'. Unable to fetch URL from any source.
                  ERROR: Logfile of failure stored in: /home/zhumy/galileo/test_galileo/meta-clanton_                                                                                                                  v1.0.1/yocto_build/tmp/work/i586-poky-linux-uclibc/libvpx/0.9.5-r3.0/temp/log.do_fe                                                                                                                  tch.26516
                  ERROR: Task 2236 (/home/zhumy/galileo/test_galileo/meta-clanton_v1.0.1/meta-oe/meta                                                                                                                  -oe/recipes-multimedia/webm/libvpx_0.9.5.bb, do_fetch) failed with exit code '1'
                  NOTE: Tasks Summary: Attempted 1256 tasks of which 785 didn't need to be rerun and 1 failed.
                  Waiting for 0 running tasks to finish:

                  Summary: 1 task failed:
                    /home/zhumy/galileo/test_galileo/meta-clanton_v1.0.1/meta-oe/meta-oe/recipes-multimedia/webm/libvpx_0.9.5.bb, do_fetch
                  Summary: There were 4 WARNING messages shown.
                  Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

                  • 7. Re: Installing opencv on Intel Galileo
                    AlexT_Intel

                    You have some networking problems, according to the log it's not able to download the packages with sources. Check that you have setup proxy if your network uses a proxy, try downloading the files mentioned in the error message directly using wget - these two things is what I'd check first.